Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As we all know, trying to force Qt Creator to use qmlscene instead of qmlviewer is like trying to force Eclipse, after already having installed JDT, to use CDT instead. Googling "No qmlviewer installed", of course, does return this Qt forum result, but there's no way in the world the "-qpa" flag is the default Qt Creator behavior.

By the way, yes I HAVE registered qmlscene with Qt Creator (as an external tool), and yes, I HAVE tried to get Qt 5 working with the Creator (to no avail). As for the PATH variable: It's defined system-wide, in /etc/bash.bashrc and /etc/profile (respectively) and "echo $PATH" does reveal /opt/qt5/bin in there. And even qmlscene causes problems, as described here, only on an Ubuntu 12.10 machine. So there's no reason for Qt Creator to be acting up.

Thanks for the help in advance...

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.