Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've started playing minecraft, on my windows pc it works flawless but when playing on my ubuntu laptop it runs verry slow. I allready put all minecraft settings to minimal, i'm running oracle java 7 and opengl is supported. this are my specs:

  • lenovo Thinkpad X61s
  • Ubuntu 12.10 64bit
  • gnome-shell
  • 4G RAM
  • CPU: Intel® Core™2 Duo CPU L7500 @ 1.60GHz × 2
  • GPU: Intel® 965GM
  • 64G SSD

Appart from my gpu it looks like decent specs to me, is it just the gpu that slows it down or could i do something to speed it up?

Thanks in advance

share|improve this question
Have you installed any drivers for your GPU? – Seth Jan 21 '13 at 16:23
I added some intel driver ppa's, but no packages where updated. i didn't install any packages manually – 19J94V Jan 21 '13 at 20:27
This might help:… – Luis Alvarado Jan 21 '13 at 20:31
tried the steps but still hanging at 6-7 fps (see screenshot: – 19J94V Jan 21 '13 at 20:52
How much ram are you giving to your client? the recommeded amout of ram to play Vanilla is about 2GB also if you cannot dedicate that much ram to the client as requested above is it use optifine. i hope i have enhanced you gaming experiance :) – R3ido101 Jul 19 at 10:21

2 Answers 2

You could try give it more RAM, this is how I did it:

-Xmx2G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
share|improve this answer
Its in the JVM arguments: – TheAssassin7187 Sep 12 at 11:26

What you might want to try is Optifine, a minecraft lagg stop which lets you customize the game settings even more into depth. just google it and download the version for whatever version of minecraft you have, then mark the file as executable ( in the properties menu (right click) ) an then run. it will install optifine then run minecraft launcher, then choose the optifine minecraft version (Ex: optifine 1.8.1) and run. once that is done, go to settings and explore the settings and tweak them. this should work, it did for me, Good luck :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.