Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to install a Canon printer, and getting into trouble at some point (see this question, regarding the 12.10 part) I noticed that I had not followed exactly what Ubuntu Documentation recommended for 12.04: I had installed version 2.4 of the canon driver while the ubuntu website gave a link for v.2.3.

While with 2.4 i have stumbled on the step presented in that question, after removing drivers and trying to install 2.3 version (cndrvcups-common_2.30-1_i386), i have an unsatisfied dependency: gs-esp

enter image description here

But how to install that?

Cannot find it in Synaptic

If i enter

apt-cache show ghostscript | grep ^Provides

i only get

Provides: postscript-viewer

Output of apt-cache policy ghostscript is

Installed: 9.06~dfsg-0ubuntu4
  Candidate: 9.06~dfsg-0ubuntu4
  Version table:
 *** 9.06~dfsg-0ubuntu4 0
        500 quantal/main i386 Packages
        100 /var/lib/dpkg/status


$ sudo dpkg -i cndrvcups-common_2.30-1_i386.deb
Selecting previously unselected package cndrvcups-common.
(Reading database ... 388209 files and directories currently installed.)
Unpacking cndrvcups-common (from cndrvcups-common_2.30-1_i386.deb) ...
dpkg: dependency problems prevent configuration of cndrvcups-common:
 cndrvcups-common depends on gs-esp; however:
  Package gs-esp is not installed.

dpkg: error processing cndrvcups-common (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
share|improve this question
up vote 0 down vote accepted

The 2.40 version package you have there is just depending on this:

Depends: [...] gs-esp | ghostscript (>= 9.00) [...]

meaning this is an OR relationship, so the ghostscript version 9.05~dfsg-0ubuntu4.2 (precise) or 9.06~dfsg-0ubuntu4 (quantal) in Ubuntu will satisfy it.

Whereas the 2.30 version of the package has these dependencies:

Depends: [...], gs-esp, [...]

The package ghostscript provides this in 12.04:

apt-cache show ghostscript | grep ^Provides
Provides: gs-esp, postscript-viewer

But not in 12.10.

Bottom line: Unless you want to modify this binary-only package, this 2.30 version is not installable on 12.10 and up. Use the 2.40 version.

share|improve this answer
@cipricus Ah, now I see your problem. It's just with 2.30 you have an issue with and not with 2.40. Well, that's by design, the 2.30 is only for 11.10 and may work on 12.04 as well, but not on 12.10. We could hack the debian/control file, but this might break more. – gertvdijk Jan 21 '13 at 16:58
@cipricus I'm not gonna do the hacking here on the package. It's a package without sources as far as I can see. Regular packages are easy to patch. This is a nasty piece of tarring, arring and md5'ing, without a source package. – gertvdijk Jan 21 '13 at 17:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.