Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed LAMPP with these instructions, but phpmadmin didn't work so i tried to uninstall and then install it again and it still doesn't work. When I'm trying to turn it on i get these errors.

jeggy@jeggy-12:~/Niðurtøkur$ sudo /opt/lampp/lampp start
Starting XAMPP for Linux 1.8.1...
XAMPP: Another web server daemon is already running.
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.
jeggy@jeggy-12:~/Niðurtøkur$ 

I have tried

sudo /etc/init.d/apache2 stop

and

sudo /usr/sbin/apache2ctl stop

And none of them work


When i go to localhost/phpmyadmin/ i get this error: enter image description here


EDIT: Now i get this error

jeggy@jeggy-12:~/Niðurtøkur/nspire$ sudo /opt/lampp/lampp start
Starting XAMPP for Linux 1.8.1...
XAMPP: Starting Apache...
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

enter image description here

share|improve this question
    
"XAMPP: Another web server daemon is already running." Is there another web server running? If so ... kill it. –  Rinzwind Jan 22 '13 at 14:55
    
i know that, but i don't know how to kill it. What i think it can be is that it was on while i deleted it and now when i installed it again it says another already is on –  Jeggy Jan 22 '13 at 16:14
    
ps -ef|grep {whatyouwanttofind}, find the PID, and do a kill -9 {pid}. {whatyouwanttofind} is something like mysql or xampp. –  Rinzwind Jan 22 '13 at 18:52
    
Ughh, please don't use XAMPP on Linux. We have a perfectly fine LAMPP stack in the package repositories: trivial, single-command installation, much better system integration (incl. better file access permission management), and completely automated (security) updates. –  David Foerster 1 hour ago

2 Answers 2

up vote -1 down vote accepted

After being googling for days i found this and it works great!

What i did was

sudo chmod 755 /opt/lampp/etc/my.cnf
sudo chmod 777 /opt/lampp/var/mysql -R
sudo /opt/lampp/lampp restart

and now it works

share|improve this answer
1  
Making a whole directory structure writeable and executable to everyone is a terrible idea. –  David Foerster 1 hour ago

I am confused after I install XAMPP. I get something like this:

/opt/lampp/lampp: line 126: /opt/lampp/share/lampp/selinux: No such file or directory
Starting XAMPP for Linux 1.7.7...
/opt/lampp/lampp: line 133: /opt/lampp/share/lampp/nogroupcheck: No such file or directory
/opt/lampp/lampp: line 126: /opt/lampp/share/lampp/selinux: No such file or directory
/opt/lampp/lampp: line 126: /opt/lampp/share/lampp/selinux: No such file or directory
/opt/lampp/lampp: line 506: /opt/lampp/share/lampp/phpstatus: No such file or directory
XAMPP: Starting Apache...
XAMPP: Error 1! Couldn't start Apache!
/opt/lampp/lampp: line 233: /opt/lampp/share/lampp/diagnose: No such file or directory
/opt/lampp/lampp: line 126: /opt/lampp/share/lampp/selinux: No such file or directory
XAMPP: Starting MySQL...
/opt/lampp/lampp: line 253: /opt/lampp/bin/mysql.server: No such file or directory
XAMPP: Couldn't start MySQL!
/opt/lampp/lampp: line 126: /opt/lampp/share/lampp/selinux: No such file or directory
/opt/lampp/lampp: line 140: /opt/lampp/share/lampp/alladdons: No such file or directory
XAMPP for Linux started.

What is wrong when I install? I'm new to Ubuntu users. Please advise and help ..

thanks..

share|improve this answer
    
Welcome to Ask Ubuntu! ;-) We're very sorry, but this is not a good place to put another question as the only people seeing your "answer" will be the original poster and a bunch of reviewers trying to review your "answer" for quality... So please first look over the existing answers and if none of them work, ask a new question and refer back to this question and explain what went wrong. ;-) –  Fabby 1 hour ago
    
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. –  Elder Geek 38 mins ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.