Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to isntall Xen on ubuntu 12.04 LTS for the first time (running on blade server, 8GB ram, without the naughty iscsi controller, running LSISAS1064E)

I've followed the official ubuntu instructions and got the infamous "(XEN) Not enough memory to relocate the dom0 Kernel image" error.

I tried building the kernel with dom0 support manually (by following the Xen's Mainline Linux Kernel Configs) as suggested in the ubuntu forums but I keep receiving the error even with my kernels (needless to say the ubuntu OS boots fine with them).

I've tried the latest stable kernel (3.7.4) using both ubuntu's kernel and manual build from the official sources as well as 3.8.0-rc4 (from kernel.org)

I've tried setting the dom0 ram size in /etc/default/grub:

GRUB_DEFAULT="Xen 4.1-amd64"
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=30
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX="rootdelay=180"

GRUB_DISABLE_OS_PROBER=true
GRUB_CMDLINE_LINUX="apparmor=0"
GRUB_CMDLINE_XEN_DEFAULT="dom0_mem=512M"

Switched the default stack to xl (as advised here) and just to be sure - the default bios boot option is the SAS. Yet, I still keep getting the error. I tried google-ing it but most of the answers are about the QLogic iSCSI controller.

Am I missing something or should I go back to vmaware ?

share|improve this question
add comment

1 Answer

I had exactly the same issue and ended up trying pretty much the same thing. Under Xen 4.2.1 and kernel 3.7.9 try setting the line in /etc/default/grub:

GRUB_CMDLINE_XEN_DEFAULT="dom0_mem=512M,max:512M no-real-mode e820-verbose"

This seems to get around the memory problem, although I find it then hits other problems (comes up with just 1 CPU and then hangs running the script/local-premount - these may be due to my config though).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.