Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Though the Software center is showing that "Adobe Flash Plugin" is installed in my computer, which is a Compaq Presario c700 running Ubuntu 12.04 LTS, yet some websites like www.youtube.com is prompting me to download Adobe Flash Plugin to view online streaming. PS: I have the latest version of Adobe Flash Plugin

share|improve this question
    
Welcome to Ask Ubuntu! Please include the output of dpkg -l \*flash\* run from a terminal and include what browser you're using. Do this by editing your question. –  gertvdijk Jan 21 '13 at 13:40
    
you might want to avoid flash atleast for youtube by enabling HTML5 mode in youtube. –  hatter Oct 23 '13 at 2:54

3 Answers 3

I ran into the same issue. dpkg showed that flashplugin-installer was already installed but no flash in Firefox. I resolved it by running

sudo apt-get --reinstall install flashplugin-installer
share|improve this answer

After encountering a problem with adobe flash player not being clickable on cam chat sites I became very aggravated..and it takes that for me to fix stuff I guess.

Remove Flash player plugin from within firefox [is what I use] use:

sudo apt-get update
sudo apt-get autoremove then,

use terminal to re-install flash plugin:

sudo apt-get install flashplugin-installer

After doing the exact above actions the adobe flash player problem was solved.

share|improve this answer

I had the same issue before, on another computer, and after trying countless different ways to fix it (including completely removing and installing flashplugin-installer, adobe-flashplugin, the version from adobe's website, pepper flash, etc...), I finally fixed it by using an older version of flash.

I basically went here: http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html, then I downloaded 11.1 (no real reason why, it's just because I didn't want to try each version, so I decided that it would be better to have a version too old, than to have to download test each one).

I installed flashplugin-installer again, then I extracted the archive, went to fp_11.1.102.63_archive -> 11_1r102_63_32bit (change 32bit to 64bit if your system is 64-bit), extracted flashplayer11_1r102_63_linux.i386.tar.gz (replace i386 to x86_64 if you system is 64-bit), and then copied libflashplayer.so to /usr/lib/flashplugin-installer/.

After I had restarted chromium, everything worked fine! This should work for firefox too.

There is a copy-and-paste instruction on how to do this.

share|improve this answer

protected by Community Oct 23 '13 at 8:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.