Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't open LibreOffice anymore, neither Writer nor Calc.

  1. If I try it from the launcher, the icons flash a few times and then stop. The LibreOffice start window emerges for about one second and then disappears.
  2. If I open Nautilus and click on any document assigned to LibreOffice, the LibreOffice start window emerges for about one second and then disappears.
  3. When trying it from the terminal with libreoffice --writer, for example, I see the same behavior and the following error message:

    [Java framework] Error in function createSettingsDocument (elements.cxx).
    javaldx failed! 
    Warning: failed to read path from javaldx
    terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

What can I do?

share|improve this question
up vote 3 down vote accepted

From this discussion, if it applies to you as well (first part):

The permissions are:

drwxr-xr-x  2 root root   4096 Mar  6 13:58 .config

Only folder in ~/ owned by root I might add.

that being the case

sudo chown -vR matt:users /home/matt/.config

Your user should own .config within your home folder

share|improve this answer
But won't the permissions be correct in the first place? Anyway, OP can check if there is something like this: drwxr-xr-x 2 root root 4096 Mar 6 13:58 .config. Spooky if it is! (Mine is drwx------ 28 vasa1 vasa1 4096 Jan 13 15:10 .config/ ) – user25656 Jan 21 '13 at 12:17
this worked :) Thank you very much! – Wolfson Jan 21 '13 at 12:20

I one had this problem after updating from ubuntu 13.10 to 14.04. After reinstalling libreoffice it worked. The problem then returned and or I had other issues like the program hanging up the whole system and I had to reboot.

I solved this by trial and error by changing the display driver.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.