Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install Ubuntu 10.10 from the official livedisc I got in the mail, when I get to the "Allocate Disk Space" step I cannot get it to work. I shrank my win7 partition so I have unallocated space, then I tried using the space while it is formatted in NTFS, but the partitions will not show up in the box. /dev/sda is selected under boot loader, and I can't select anything else, but the partition box is blank so when I click "install ubuntu" it just says: "No root file system is defined. Please correct this from the partitioning menu."

-I am trying to dual-boot win7 and ubuntu, but I was never asked in the install process whether I would like to install just ubuntu or dual-boot?

share|improve this question
    
You chose manual partitioning and the box does not show /dev/sda? –  psusi Feb 3 '11 at 3:37
add comment

3 Answers

Open a terminal

type:

sudo apt-get remove dmraid

then type "y" then enter"

This TOTALLY worked. I did it all from 10.10 cd. Must be some RAID code interfering with the install - the new installation is terrible. Thanks for the help.

share|improve this answer
add comment

This worked for me. It is from http://ubuntuforums.org/showpost.php?p=8225121&postcount=1 . Go to the bottom and read the following: "Ultimate solution:

Boot up 9.10 Live CD

Open a terminal

type: sudo apt-get remove dmraid

then type "y" then enter

now try to install!" This solved my problem and hopefully for all of you folks also!

share|improve this answer
    
THANK YOU!!!! This did work, I did this and was able to install 10.10 successfully with the Live CD. –  user10134 Feb 8 '11 at 5:49
add comment

i guess you are doing it wrong. dont install ubuntu without reading the manual for advanced partition. you will end up deleting win 7 altogether! check this tutotrial.

http://www.howtoplaza.com/how-to-install-ubuntu-904-on-a-manually-created-partition

it is based on ubuntu 9.04 but idea is the same. you need to create 2 partitions. one for swap and another for root. check the screenshots in that tutorial. if u still have confusion, come back and post q's again.

share|improve this answer
    
When I try to install it, it never shows me this step ubuntu.com/sites/default/files/active/maverick/… I don't get the option of how I want to install it, instead it goes to a screen where it wants to prepare the partitions, but doesn't show the partitions. 2.bp.blogspot.com/_JBHfzEovWs8/TMWkviQT0VI/AAAAAAAAAxE/… this is what it brings me to instead of showing me that step, but the bar at the top is empty, the box is empty, and I can't select anything besides /dev/sda –  user10134 Feb 5 '11 at 2:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.