Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have EFI Windows 8 in my Asus K55V laptop. EFI partition is sda1.

I tried to install Ubuntu in EFI mode and created/selected separate boot partition for Ubuntu boot loader.

Ubuntu installed perfectly, but I got 2 boot entries in EFI setup. When I tried to delete it in EFI setup (bios screen), it restored on restart.

So I tried doing boot-repair from live-usb, the thing is it added GRUB2 to my sda partition. And it did not solve the 2 Ubuntu boot entries. So I deleted the Ubuntu partitions (boot/swap/mount) to remove Ubuntu from my laptop.

Now the problem is that GRUB2 which is in sda is listed in EFI Boot selector (without Ubuntu actually installed).

Check this

I need two solutions:

  1. How do I remove GRUB2 from sda partition?
  2. How to install Ubuntu without getting 2 boot entries? Should I select the sda1 (EFI partition) as boot loader partition when installing Ubuntu?
share|improve this question
The log you provide shows no Ubuntu on the disk. Please run Boot-Repair again , and indicate the new URL that will appear. – LovinBuntu Jan 21 '13 at 22:49
@LovinBuntu yes because I formatted Ubuntu partitions. I just want to remove grub from sda. – dinodd88 Jan 22 '13 at 3:40
then just run Boot-Repair --> Adv Options --> Restore MBR --> Apply . – LovinBuntu Jan 22 '13 at 23:57

Boot from a ubuntu image in UEFI mode. Select "Try without installing".

First run sudo apt-get install efibootmgr (No need an internet connection)

Then view the entries using sudo efibootmgr -v. Which gives a lot of entries like this:

$ sudo efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,0003
Boot0000* rEFInd Boot Manager   HD(1,28,96000,bc34b60c-6611-492f-99b0-d2c37bd77f48)File(\EFI\refind\shim.efi)
Boot0001* fedora    HD(1,28,96000,bc34b60c-6611-492f-99b0-d2c37bd77f48)File(\EFI\fedora\grubx64.efi)
Boot0003* ubuntu    HD(1,28,96000,bc34b60c-6611-492f-99b0-d2c37bd77f48)File(EFI\Ubuntu\grubx64.efi)

Then try deleting an entry ubuntu using the following code

$ sudo efibootmgr -b 3 -B
share|improve this answer

In EFI, boot loaders are just files. Ubuntu's GRUB is stored as EFI/ubuntu/grubx64.efi on the EFI System Partition (ESP) -- /dev/sda1 in your case. Thus, to remove GRUB you must remove that file.

I suspect your fundamental problem isn't really the file, though; it's one of two other things (your description isn't clear enough to identify which is the case):

  • You've got two Ubuntu entries in your firmware's built-in boot manager.
  • You've got two Ubuntu entries in GRUB.

I've seen Ubuntu create two EFI boot manager entries, and on this system (based on an ASUS motherboard), they seem quite resistant to deletion. Using efibootmgr should delete the extra entry, as in efibootmgr -b 0007 -B to delete entry #7; but the on the system with this problem, the offending entry just keeps re-appearing. Perhaps this is a firmware bug, or maybe there's an Ubuntu startup script that's to blame. This isn't really all that big of a deal, since the computer normally boots to the default entry, so the only time I see the extra entries is if I need to use the firmware's boot manager to switch from my default boot loader. The one thing that got rid of the duplicate entry in my case was completely clearing all of the entries via a firmware update. Thereafter, I ended up with just one entry. Perhaps using efibootmgr to delete both entries would have a similar effect.

If you've got two Ubuntu entries in GRUB's menu, they may be there for a reason -- to boot two different kernels or to boot in two different ways (normally and to a single-user mode, for instance). I don't advise trying to adjust that, although if you're determined to do so, you could look for a tool called "GRUB Customizer" that's supposed to simplify GRUB configuration. I don't have a URL handy, though.

share|improve this answer
My problem is two Ubuntu entries in my firmware's built-in boot manager.I cannot add images as i dont have enough rep. And i will also check for firmware updates thanks. – dinodd88 Jan 23 '13 at 11:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.