Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Asus UX21A ultrabook. It's really sweet in most respects. However, there is one issue which to me is a design flaw, though maybe some people think it's a feature.

The tracking area of the touchpad and the mouse buttons overlap. I suppose some people might think this was a feature, as it means that potentially you could drag the pointer to somewhere and then click without having to lift your finger. But for me, it just ends up that sometimes when I go to click something, the pointer moves just a bit so that it moves off the thing I'm clicking and the click doesn't register. Especially with the high definition screen, where the pixels are small, which sometimes results in some really tiny interface elements.

I'd like to be able to change the area that responds to finger movement so that it is separate from the buttons.

The current effective tracking area is this, outlined in red:

bad tracking area

I'd like to change it so that the tracking area is like this, outlined in green:

enter image description here

Is it possibly to manually configure the touchpad's responsive area in this way?

share|improve this question

1 Answer 1

Not sure if this works on all touchpads (I think it should work on Synaptics and ALPS), but you could try and edit your xorg.conf and add

Option "AreaBottomEdge" "XXX"

See Ubuntu manpages for more info about the Synaptics driver options.

Option "AreaBottomEdge" "integer"

Ignore movements, scrolling and tapping which take place below this edge. The option is disabled by default and can be enabled by setting the AreaBottomEdge option to any integer value other than zero. Property: "Synaptics Area"


You can also try it live by running synclient in terminal (Ctrl+Alt+T) with options:

# synclient -l

to list current options and

# synclient AreaBottomEdge=XXX

to change the settings temporarily. When you find the right XXX edit your xorg.conf.

See also synclient manpages.

share|improve this answer
    
Thank you for this advice. When I run synclient -l, it says the valueof AreaBottomEdge is 0. However, when I run synclient AreaBottomEdge=XXX, and if I make the value of XXX anything above 0, even just 1, the mousepad stops responding entirely. If I make the value a negative number, there is no change at all. –  Questioner Jan 28 '13 at 13:04
    
@DaveMG you need to set it to something lower than your BottomEdge, by looking at the picture probably by about 20% less. Setting it to 1 means your touchpad stops working after 1 'unit' counted from top. E.G. my BottomEdge is '527' when I change AreaBottomEdge to 300 bottom half of the touchpad doesn't work –  Symin Jan 29 '13 at 18:19
    
Thanks for the further explanation. The part I missed was that one is defining the usable area starting from the top. My BottomEdge value is 1771. So I set AreaBottomEdge to 1600, and that seems to be about right. Almost there: my concern now is about how to make this adjustment permanent. I thought xorg.conf was deprecated a few Ubuntu versions ago. In any case, I do not seem to have an active xorg.conf file. I'm a little wary of just arbitrarily making one. What is the proper way to proceed given that there is no xorg.conf in the /etc/X11 directory or anywhere else? –  Questioner Jan 31 '13 at 8:24
    
@DaveMG xorg.conf is not deprecated, it just doesn't exist by default any more. Read this for more info. –  Symin Jan 31 '13 at 17:58
    
@DaveMG or instead of generating xorg.conf you could copy /usr/share/X11/xorg.conf.d/50-synaptics.conf into /etc/X11/xorg.conf.d/50-synaptics.conf and edit it accordingly. –  Symin Feb 3 '13 at 8:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.