Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After using the Wubi migration script and booting into my Ubuntu install, when I plug in my USB flash drive I receive a prompt that says "Unable to open a folder for PENDRIVE. No application is registered as handling this file." If I attempt to open the drive from the launcher, nothing happens.

Any idea why this might be happening?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

This has something to do with the ACLs (access control lists). I'm not sure when the problem started (I think with release 12.10), but ironically it happened to me last week so I knew what to look for.

Anyway here is the low down... if you check the access control list on the Wubi install it looks like this:

# file: media/bcbc
# owner: root
# group: root
user::rwx
user:bcbc:r-x
group::---
mask::r-x
other::---

Whereas on the migrated install it looks like this:

bcbc@23:34:50:~$ getfacl /media/bcbc
getfacl: Removing leading '/' from absolute path names
# file: media/bcbc
# owner: root
# group: root
user::rwx
group::r-x
other::---

As you can see it's missing this: user:bcbc:r-x

Solution

The simplest solution is to remove the directory as it gets recreated automatically (substituting your username in place of bcbc):

sudo rmdir /media/bcbc

Or you can simply reinstate the ACL by running the following command (again substituting your username, twice):

sudo setfacl -m u:bcbc:rx /media/bcbc

This is what it looks like:

bcbc@23:34:53:~$ sudo setfacl -m u:bcbc:rx /media/bcbc
[sudo] password for bcbc: 
bcbc@23:35:42:~$ getfacl /media/bcbc
getfacl: Removing leading '/' from absolute path names
# file: media/bcbc
# owner: root
# group: root
user::rwx
user:bcbc:r-x
group::r-x
mask::r-x
other::---

bcbc@23:35:44:~$ 

I've marked it as an issue on the migration script (wiki and github) and will fix it in the next release, probably need to add the -A option to the rsync commands to copy across the access control list.

share|improve this answer
1  
This worked perfectly. Thank you! –  ForSpareParts Jan 22 '13 at 9:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.