Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
  1. I have setup transfer to IPs & master/slave directories/files
  2. Added /etc/bind/rndc.key file with the same pass-phrase on both master/slave
  3. Permission items inside /etc/bind/slave are -rw-r--r-- (Also tried -rw-rw-rw without any success)
  4. Edited /etc/apparmor.d/usr.sbin.named


/etc/bind/slave/** rw,

/etc/bind/master/** rw,

/etc/bind/ rw,

I then do sudo /etc/init.d/aparmor restart & then run rndc reload (Zone name)

I wait like 5-10 minutes and go to "vi /var/log/syslog" & it compares the serial number between the Master & Slave but then I get these issues:-

ns named [939]: zone refresh: could not set file modification time of '/etc/bind/slave/': permission denied


ns named [939] dumping master file: /etc/bind/slave/tmp-FEhwr4afaX: open: permission denied

Using Ubuntu Server 12.04.1 LTS.

Hopefully someone can help me get this RNDC (Sync) occurring as I am out of ideas at the moment.

(Tried modifying folder/file permissions & edited apparmor without any luck)

Also since I migrated from a Openbsd bind9 to Ubuntu bind9 my files structure is a slightly different as I only have a single named configuration file

eg. master






share|improve this question

I solved the issue myself.

  1. Create a folder called slaves under /etc/bind/
  2. Go into named.conf & replace /etc/bind/slave with /etc/bind/slaves & let it propergate.

You don't need any of the zone files as it will grab them from the Primary name server.

  1. RNDC reload zonename (Speeds it up for that single domain)

I think because I copied the slave folder from another system the permissions were root:bind & the new folder that was created was bind:bind which is why it works.

But it's odd I did change the permissions on the folder/files to bind:bind but the main thing is its working now.

Hopefully this helps others who are migrating form an OpenBSD Name Server etc

share|improve this answer

Since the answer did not fix the exact same issue for me, here is what I had to do (which I searched online without success and tried to fix this for 2 hours)

I had to simply modify one line in /etc/default/bind


# run resolvconf?


# run resolvconf?
share|improve this answer
That is certainly not the solution to the stated problem. – jdthood Jul 10 '13 at 17:49
Had the exact same issue, tried everything I got from google, this worked. – bksunday Jul 10 '13 at 21:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.