Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It used to be that I could go up to the top of my desktop and there would be a file, edit etc. Now when I move my cursor over the words "Ubuntu Desktop" nothing happens. Also the "Add a launcher" entry when I right click my desktop is gone. Any ideas? Sorry if this question is poorly worded.

Even when I have the mouse over it it still shows this:

share|improve this question
    
Can you add a screenshot showing what it looks like? –  Seth Mar 5 '13 at 0:26
    
A screen shot would be useful - also are you using Nautilus for your file-manager or are you using another file-manager? What happens if you reset your settings as per this Q&A askubuntu.com/questions/17610/… –  fossfreedom Mar 9 '13 at 14:42
    
Nautilus... I will add the picture momentarily –  chad Mar 10 '13 at 0:25
add comment

3 Answers 3

up vote 1 down vote accepted
+50

Perhaps you've gotten Nautilus 3.6, where Gnome removed a lot of the menus and other elements of the file manager.

What version of Ubuntu, and Nautilus, are you running? My desktop in Raring, with Nautilus 3.6.3 at the moment, behaves the same as yours. Gnome cut out a lot of the interface in 3.6; it pained a lot of users. Ubuntu stuck with the older version for 12.10. Here's one description of the changes, from last year.

Linux Mint, an Ubuntu derivative, created a fork called Nemo, from Nautilus 3.4, the stable version before all the removals. I haven't run that myself, and I don't know if there are any caveats in running it to manage your desktop with Unity. Here's a description from another Ubuntu news site, of using Nemo from a PPA.

Does it sound like this is what you're seeing?

share|improve this answer
add comment

Open your terminal (Ctrl+Alt+T) and run this command:

sudo apt-get update && sudo apt-get install appmenu-gtk indicator-applet-appmenu indicator-appmenu

That will install the packages to make application menus appear in the top panel.

share|improve this answer
    
This did nothing. I installed the packages and then restarted my computer. When I go up to the menu bar I have the same problem –  chad Jan 21 '13 at 17:54
add comment

I dont't think that will get you creating a launcher. To add a laucher, you need Gnome panel. See here how to get that and create a laucher:

http://www.howopensource.com/2012/10/create-application-launcher-add-icon-to-unity-ubuntu-12-10/

share|improve this answer
    
thank you i am aware of this in fact I have a script for this on my desktop for easy access What i used to be able to do is right click the desktop and an option would come up to create the launcher –  chad Jan 21 '13 at 17:36
1  
Hi, even the link may have exact answer , Its nice to mention the exact answer or part of answer here for Future purpose. –  AgentCool Feb 21 '13 at 1:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.