Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i have a Samsung N150, a windows 7 machine and recently installed - for the first time - ubuntu. the install was successful apart for an issue with wireless connection. When i check the connection status my netbook states i am connected to my wireless router but as i try to open firefox i get the message "server not found".

05:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192E/RTL8192SE     
Wireless LAN Controller [10ec:8192] (rev 01)
09:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8040 PCI-E Fast 
Ethernet Controller [11ab:4354]

i tried connecting the laptop to a wired connection and it worked fine. i also know my laptop has no issue with wireless connection as i could connect to the internet fine through windows. i am also able to access the internet on other devices.

i am just unable to access the internet wirelessly even though it comes up on the laptop as connected. if anyone has come across this problem or knows how to solve it please help as it is driving me crazy.

share|improve this question

I was able to fix this problem, by running these commands:

sudo rmmod -f ath5k
sudo rfkill unblock all
sudo modprobe ath5k
share|improve this answer

This should actually be a comment on your post, not an answer but I don't have that privilege yet so site admins go easy on me plz :). As no one is picking this up, i'll have a go. For the moment we'll assume that there is no driver issue. We might be proven wrong later though.

Try doing a few tests:

boot into linux without the wired connection. in a terminal window type:

ping (type ctrl + C to stop the output)



and post the results (as an edit to your question)

then enter the folowing commands 3 into the terminal:

ifconfig -a


sudo lshw -C network

And again, copy the output back here

gd luck.

@Kris: Your removing and reloading a kernel module for an Atheros driver. How do you know he has that kind of card?

Doing "sudo rfkill unblock all" might do the trick but could potentialy do damage as well. Lets see "sudo rfkill list" first then.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.