Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I love my CTH-470 and I'm glad it's without having to spend hours in the Terminal to get it working since I believe 12.10 (which I'm running now). But in the manual it states that you can swipe with three or even four fingers.

However, I can't seem to find how to 'activate' this on Ubuntu.

  • Is this even possible?
  • If yes, how?
  • And if no, are there any plans to support this in the future?
share|improve this question
    
I'm using a Wacom Bamboo Pen & Touch CTH-460/K on Ubuntu 12.04. This also supports three and four finger touch (that's what the /K is for, apparently; under Windows I've tested this to be the case). Under Ubuntu, it does no more than 2 fingers. I see the following when running "dmesg | grep Wacom": input: Wacom BambooPT 2FG 4x5 Finger -- looks like the driver picks it up as a 2-finger touch (2FG) device. What does it say in your dmesg? –  Charl Botha Feb 3 '13 at 14:12
    
@CharlBotha It says 'input: Wacom Bamboo 16FG 4x5 Finger as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/input/input5', though I don't think it would be physically possible one could use 16 fingers, so are you sure it expresses the amount of fingers it should/could support? By the way, it shows the same line twice, except for 'Finger', which is 'Pen' on the other line. –  FMJansen Feb 6 '13 at 20:40
    
12.10 hasn't been supported for a while now, I recommend you install either 15.04 or 14.04 LTS, and continue from there. –  codingman Jul 1 at 2:45
    
I'm using Ubuntu 14.04 and the same problem still exists. You can use it as a tablet, and you can use it to point, click and two-finger-scroll. No other gestures are supported by default. I'm also interested in solutions to this. –  verpfeilt Jul 26 at 19:29
1  
have you tried manually adding it via xinput ? –  AliReza Mosajjal Aug 9 at 6:54

1 Answer 1

According to an older post on the forum[1], it's better to use Ubuntu's native touch support and I will condense the information that fixed this issue:

Update or make sure you're using version 0.20.0 or above for xf86-input-wacom driver package:

xsetwacom -V

Install touchegg package:

sudo apt-get install touchegg

Turn OFF wacom's own touch guesture support so ubuntu's touchegg can take guesture control:

xsetwacom set "Wacom Bamboo 16FG 4x5 Finger touch" Gesture off

You may need to replace the name above in quotes with the name of your finger pen device name which you can find doing xsetwacom --list devices

Use the touchegg configuration tool or edit the touchegg configuration file to adjust timeouts as needed.

You should now have working multi-touch support.

[1] http://ubuntuforums.org/archive/index.php/t-2125990.html

share|improve this answer
    
Thanks for posting this. Important to note: I'm sirolf10 at the ubuntuforums. So yes, this did work, but not that great. "When you release your fingers after scrolling it sometimes scrolls back and you can't right-click and move your cursor directly afterwards anymore, you have to lift your finger first." This led me to stop using touchegg. It did work for the 3+ finger gestures, though. My excuses for not mentioning this earlier myself, should have done that. –  FMJansen 18 hours ago
    
That sounds very much like a half a dozen bugs in touchegg; it should be fixed rather than using a driver which isn't integrated into the system in the same way. –  Martin Owens -doctormo- 53 mins ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.