Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I really like the default vim colorscheme in 10.10 but I can't figure out what it's called -- I want to turn it on for my Debian box as well.

share|improve this question

3 Answers 3

up vote 12 down vote accepted

If you are on a light terminal, the default is peachpuff.

If you are on a dark terminal, the default is ron.

You can tell which you have by typing :set background?.

(Vim guesses whether your terminal has a dark or light background based on the value of the TERM environment variable.)

I found this answer by going ":color Tab" and choosing each option, then comparing it to the default.

share|improve this answer
    
it could be elflord I suppose but it looks like ron. thanks! –  wickedchicken Feb 2 '11 at 23:14
2  
Actually, the default colorscheme is named "default". You can use it by calling :colorscheme default. Peachpuff and ron are different from the default. –  graywh Mar 2 '11 at 20:28
    
There are different defaults depending on whether your terminal is classified as having a dark or light background. default and peachpuff seem to be identical to me, but if you're on a dark terminal, doing :colorscheme default does not give you the default colorscheme, whereas :colorscheme ron looks the same as what you get automatically. –  Mikel Mar 2 '11 at 20:52
    
Actually, /usr/share/vim/vimcurrent/syntax/syncolor.vim seems to be involved as well. –  Mikel Mar 2 '11 at 20:59
    
Thanks Mikel. The colorscheme default was not giving intended result because some one down in my vimrc the xterm background setting was set to "dark" which was causing all cyan and yellow colors to be picked up. As soon as I commented them out it worked. –  user12274 Mar 13 '11 at 4:36

It's /usr/share/vim/vim72/colors/default.vim. On the Debian side, mkdir -p ~/.vim/colors and then copy default.vim to that new directory. Open your ~/.vimrc and add the line colorscheme default to use it all the time, or colorscheme ubuntu if you renamed the default.vim to ubuntu.vim.

share|improve this answer

I am not at my ubuntu box, at the moment... but by default the vim colorschemes are stored to the "/usr/share/vim/vim72/colors/" directory. The default scheme should be named unimaginatively "default.vim"

In vim you can use ":help colorscheme" to see how to best enable to color scheme in your debian box. I would recommend that, you would install the colorscheme in your .vim profile directory.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.