Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have got the following problem. I am trying to connect my Ubuntu machine to a wireless network (WPA2 Personal). I am sure that I am providing the correct key, however I am not able to connect to the network. On the other hand there is completely no problem connecting to this network from a Windows machine nor from a mobile device (Android).

Also there is no problem connecting to a WPA2 network provided by a router set up on a smart phone, so this does not look like a hardware issue of an old machine.

Has anybody stumbled upon a similar problem?

UPDATE: After a very interesting discussion with gertvdijk it turned out that this is highly probable that the problem here is that the network I am connecting to. It uses CCMP and not TKIP. I am not able to change this, so I am looking for another solution. The wireless card seems to have CIPHER-CCMP on its list.

EDIT: The output of lspci -nn | grep 0280 is:

02:02.0 Network controller [0280]: Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter [8086:1034] (rev 04)

EDIT: The results of sudo iwlist eth1 auth are as follows

Authentication capabilities :
    WPA
    WPA2
    CIPHER-TKIP
    CIPHER-CCMP
Current WPA version :
    Unknown
Current key management
    Unknown
Current Pairwise cipher
    WEP-104
    Unknown
Current TKIP countermeasures: yes
Current Drop unencrypted: yes
Current Authentication algorithm :
Current Receive unencrypted EAPOL: no
Current Roaming control: yes
Current Privacy invoked: yes 

EDIT: The results of executing cat /var/log/syslog | grep etwork | tail -n20 are posted here

EDIT: After executing dmesg there is a message that "worries" me.

[260.506187] ipw2100: Can't get TKIP countermeasures: crypt not set!

EDIT: The outcome of sudo iwlist eth1 scan is here. The network I am trying to connect to is named TheWirelessIAmTryingToConnectTo. All the other network names have been changed by me.

share|improve this question
    
Could you try the sequence of these commands: sudo iwconfig eth1 power off, sudo iwconfig eth1 power on, sudo service network-manager restart and try to connect again. Reported as a work around here. –  gertvdijk Jan 24 '13 at 16:20
    
No, unfortunately, it does not work. But I want to underline once again, the machine can connect to another WPA2 network without any problem. The one I am trying to connect to is from FRITZ!Box which is a German internet provider. I can connect to this network flawlessly from a Windows machine. Is it possible to cut off a specific operating system on some routers? Are those pieces of information even sent while connecting to a wireless network? –  Jagger Jan 24 '13 at 20:02
    
@gertvdijk I have found some discussion here. It is in German but the guy there recommends installing a backports package for the kernel, it is for 2.6.32 though. Is there something similar for 3.2.0? –  Jagger Jan 24 '13 at 20:34
    
Yes, just install linux-backports-modules-cw-3.6-precise-generic (or -pae if you're running PAE). These are wireless kernel modules from the 3.6 kernel backported to the regular Precise kernel. However, the discussion in German is a long time ago and these patches should already be in since 10.10. –  gertvdijk Jan 24 '13 at 20:38
    
@gertvdijk I also run dmesg as recommended in this discussion. I posted the message that worries me as an update to the question. –  Jagger Jan 24 '13 at 20:44
show 3 more comments

2 Answers

up vote 3 down vote accepted
+100

Some background on the issue:

thinkpads.com > Help:WPA2 on T42p Intel LAN 2100 3B wireless mini PCI card

.. the 2100 card does not support WPA2 encryption. If you absolutely need WPA2, you will need to upgrade to a newer card that supports it. I believe that the 2300 series of Intel's wireless cards do and ever card made after that.

and later ..

.. I am a happy user of T40 with Intel 2100b card and I was searching for WPA2 functionality too. I found some info on Intel's website and it looks like some 2100b cards have WPA2 support. However, even after upgrading to latest drivers, I still see WPA (WPA-PSK) option only (using winxp)...


Intel Support page

intel.com > Intel® Centrino® Wi-Fi Products

Stronger security

Your network is still vulnerable, even after you enable the security settings defined in the 802.11b standard, and the security settings of your hardware. Here are a few things you can do to improve security, making it harder for outsiders to access your network:

and specifically ..

Intel® Centrino® mobile technology users with Intel® PRO/Wireless 2100 Network Connection are recommended to upgrade systems to the latest software.

Discontinued Products > Intel® PRO/Wireless 2100 Network Connection

(page not currently available)


Conclusions:

The laptop vendors did not solve the driver issue for WPA2/AES (on Intel 2100), but Intel has released updated drivers (for Windows) that do properly support 802.11g and WPA2/AES on various Lenovo and Toshiba laptops.

You need to figure out how to replicate this on Ubuntu, or use an alternate WiFi card.

Note: I would also avoid WEP, WPA, TKIP, (or combinations) - due to their security limitations.

share|improve this answer
    
Thanks for this deep analysis. As soon as I gain more than 14 points I will upvote you answer. :) –  Jagger Jan 25 '13 at 8:41
1  
Oh thank goodness, this was driving me nuts. Pay attention to the "security settings defined in the 802.11b standard" phrase. We'd turned off "b" on our wireless device, and our T41 with the 2100b card suddenly lost the ability to connect. We had never noticed that it connected to WPA2 only as a "b" device. –  Charles Aug 17 '13 at 1:31
add comment

This is unfortunately a hardware limitation in the T40.

http://forums.lenovo.com/t5/T61-and-prior-T-series-ThinkPad/T40-WLAN-With-WPA-WPA2/td-p/95928

Edit: Apparently it works on windows with an updated driver.

http://support.lenovo.com/en_US/research/hints-or-tips/detail.page?&LegacyDocID=MIGR-61225

share|improve this answer
    
This is very strange because this computer had Windows XP on board some time ago and there were no problems connecting to a WPA/WPA2 wireless network. –  Jagger Jan 20 '13 at 19:29
    
@Jagger I was also considering resurrecting a T40 when I encountered this. I also thought I had used Windows on that same network. I later recalled upgrading the network from WEP. Could this be your case too? –  Captain Giraffe Jan 20 '13 at 19:39
    
No, I am pretty sure this was not a WEP network. I have made another test. As my smartphone has a router function I have set up another wireless WPA2 network and there is no problem connecting to that network from Ubuntu. Any other ideas? –  Jagger Jan 20 '13 at 19:51
    
Surely not a hardware problem. The wireless network I set on my smartphone is WPA2 and the laptop has no problem connecting to this network. –  Jagger Jan 20 '13 at 20:16
1  
Your card IS capable of connecting to WPA2 and is currently connected to a WEP network. Are there any clues here as you try and fail to connect to the desired network? cat /var/log/syslog | grep etwork | tail -n20. You can post the result here and give us the link: paste.ubuntu.com Does it help if you try a driver parameter? sudo modprobe -r ipw2100 && sudo modprobe ipw2100 mode=0 –  chili555 Jan 22 '13 at 15:22
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.