Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I remove or autohide to 0 the bottom Gnome panel from a remastered liveCD and autostart AWN (or any dock for that matter...) to replace it? , just as moonOS 4 (the distro that gave me the idea to try to do this)

Using this command to enable the auto hide

 gconftool-2 -t bool -s /apps/panel/default_setup/toplevels/bottom_panel/auto_hide "true"

i Figured out how to Autostart AWN,however that involves removing BOTH panels, so im not quite there yet

Using UCK gconf-editor to manually edit the option to auto hide the bottom panel doesn't work, when testing the livecd BOTH panels are still there, even though i use the command and then run gconf-editor to check that the option is enabled, which it is, however, once the livecd starts the autohide feature is disabled, why is that ?

share|improve this question

closed as too localized by Marco Ceppi Oct 30 '11 at 9:59

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
a lot of the livecd remastering tools strip user settings when they "convert to live". this might be your problem. –  hbdgaf Feb 7 '11 at 17:48
    
mmm, but removing the gnome-panels to autostart awn, it's also a user setting, why that setting it's not affected by that? –  Uri Herrera Feb 7 '11 at 20:18
    
also, it must be possible since the moonOS guys managed to do it –  Uri Herrera Feb 7 '11 at 22:28

2 Answers 2

you need to make the changes in your profile and then copy the changes over to /etc/skel and /root. The changes will be in gconf2 folder if i am not wrong.

share|improve this answer
    
i'll create a new user as to no affect my own, apply the settings i want, how do i export the keys?, or what files do i need to replace?, in /etc/skel/ there's only a video and a song? –  Uri Herrera Feb 3 '11 at 9:37
1  
sudo -s cp -Rf .config/ .fontconfig/ .gconf/ .gconfd/ .gnome2/ .mozilla/ .nautilus/ /etc/skel/ cp -Rf .config/ .fontconfig/ .gconf/ .gconfd/ .gnome2/ .mozilla/ .nautilus/ /root/ cd /etc/skel chown -R root:root .config/ .fontconfig/ .gconf/ .gconfd/ .gnome2/ .mozilla/ .nautilus/ cd /root chown -R root:root .config/ .fontconfig/ .gconf/ .gconfd/ .gnome2/ .mozilla/ .nautilus/ –  Ubuntuser Feb 3 '11 at 21:03
    
for detailed information visit this link... crunchbanglinux.org/forums/topic/2859/… –  Ubuntuser Feb 3 '11 at 21:04
    
ok, i'll give it a try –  Uri Herrera Feb 4 '11 at 4:29
1  
it should work as I have done it following the above instructions. If I may suggest, try to start from a clean install in a virtualbox setup. –  Ubuntuser Feb 11 '11 at 14:23

You can actually set it from the GUI too.

To remove the panel, right-click it, and delete it. You can make AWN autostart in its settings - it's been on the main page on all version I've seen.

share|improve this answer
    
Oh, sorry, I'm too used to live USBs. You can make a custom CD using the steps at help.ubuntu.com/community/LiveCDCustomization , and you can make the change then. –  Vallery Feb 20 '11 at 0:26
    
Still, i can't remove the bottom panel, but now AWN is on startup which is something.. –  Uri Herrera May 19 '11 at 9:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.