Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed slingshot-launcher_0.0.1~pre-0~48~natty1_i386 and everything works though it is a little slow. When I run slingshot from terminal I get the next two errors:

  1. (slingshot:1562): Critical : slingshot_frontend_indicators_set_active: assertion 'self != NULL' failed

  2. (slingshot:1562): Gtk-CRITICAL : IA_gtk_style_detach: assertion 'style->attach_count > 0' failed

I was wondering if anyone knew how to fix these errors or if there is a way to get a newer version of slingshot running on Xubuntu 12.04 with Xfce 4.10.

share|improve this question

closed as off-topic by jokerdino Aug 15 '13 at 18:38

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – jokerdino
If this question can be reworded to fit the rules in the help center, please edit the question.

    
The package is for Natty (Ubuntu 11.04), and you have Xubuntu 12.04. I guess that it is not compatible. Have you tried to install with the instructions of this answer? –  Lucio Jan 20 '13 at 0:12
    
I did but it didn't work so I had to download the .deb –  user94128 Jan 20 '13 at 0:52
    
Have you tried yo install it from source? Do you need some help with that? –  Lucio Jan 20 '13 at 1:00
    
No I haven't tried installing it from source, do you know if a newer version of slingshot would work on 12.04 if compiled from source (I know how to compile from source just never considered it) –  user94128 Jan 20 '13 at 1:01
    
I really don't know, but you should try. I must tell you that you have to remove it completely before the reinstallation. Don't forget to tell us your results! –  Lucio Jan 20 '13 at 1:09
show 1 more comment