Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to install my video drivers, in order to do so I have to shut down X-windows, but it hangs every time and will not go all the way out to prompt.

I'm using sudo init 1

I used a couple of other commands as well for this purpose with the same problem. Any ideas?

Running 12.10 64bit

share|improve this question
1  
This is the correct method: askubuntu.com/questions/116830/returning-to-the-gui (bottom answer;use stop instead of start to stop x-server). –  Rinzwind Jan 19 '13 at 22:42

1 Answer 1

Pres Ctrl+Alt+F1, login with your account, run following code:

sudo service lightdm stop

After you did your job run following to start X-Window again:

sudo service lightdm start
share|improve this answer
1  
Ubuntu 12.04 and newer. sudo service gdm stop or sudo /etc/init.d/gdm stop for older releases. –  Rinzwind Jan 19 '13 at 23:32
    
I have a same issue as the OP, on Ubuntu 12.04. Indeed, sudo service lightdm stop, from a text terminal (from the graphic terminal, it hangs) do work. However, sudo init 1 should work, or else at least, there should be something telling the user it's not implemented or not working as expected (the same when trying to shutdown lightdm from a graphic terminal). –  Hibou57 Jul 27 '13 at 19:42
    
I also just checked changing the default runlevel to 1 (setting DEFAULT_RUNLEVEL in /etc/init/rc-sysinit.conf), does not work: no terminal after the boot, and I had to Ctrl‑Alt‑Suppr to reboot and restore the default runlevel from a rescue CD. –  Hibou57 Jul 27 '13 at 20:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.