Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a freshly installed Ubuntu 12.04LTS and I wanted to use it to share an offline (wired) printer that is connected to the machine running ubuntu. I wanted to be able to print to this printer from both other Ubuntu Machines as well as Windows 7 machine. I am a newbie thus I don't really know how to do this, before I used to use Google Cloud Print but I wanted more "Local" method.

How could I accomplish that over a WiFi network?

Thank you.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

As long as your computers can see each other on the network, you should be able to share with them pretty easily (this works even if you have some computers that are on the network via Ethernet and some that are on Wifi).

The simplest way is to log on to the computer that has the printer connected to it (this is the "server"), go to "Printers," right-click the printer and make sure "Shared" is checked. If not, enable it (this may require you to install CUPS (Common Unix Print Server), which it will prompt you for, if you do).

The other Ubuntu machine should pick it up easily. If it doesn't pick it up automatically, open terminal on your server and type in ip addr and find your wireless connection (usually named "wlan0") and make note of its inet value (usually something like "192.168.1.xxx" where "xxx" is between 2 and 254). Then, on your other Ubuntu machine, in Printers, select "Add Printer". If it doesn't detect it, select "Find a Network Printer" and put in the IP address of the server and click "Find." It should pick it up from there, and the installer will walk you through.

Windows 7 has a networking option called "Home Group", make sure this is turned off (I've found that it tends to interfere with networked sharing on mixed OS networks). You can find it in the "Network and Sharing Center" section of the Control Panel. Once that's turned off, you should be able to find the printer via the "Network Printer" option of the "Printers and Devices" Add Printer wizard.

If the Windows 7 client doesn't see the printer, or won't connect to it, you may need to turn on the Internet Printing Client, as described in this Microsoft Knowledgebase Article, and use the CUPS Windows driver when the printer setup wizard asks for the driver.

Edit: If your computers can't see each other, there are a few things to do:

  1. Make sure file and print sharing is turned on (Windows) If the Windows machine doesn't see other computers, it's likely because File and Print Sharing is turned off. The Microsoft Knowledgebase has detailed instructions, but basically - go to "Network and Sharing Center," find the "File and Print Sharing" options for the details for the network you're connected to, and make sure it's turned on.

  2. Make sure all computers are on the same subnet. An IP address has four sets of numbers separated by a dot. All computers should have the same for the first three sets (such as "192.168.1.xxx"). If they don't, then you'll need to adjust the DNS software of your router to make sure they are all on the same subnet. This will vary by software, so you'll need to consult the manual or community for your particular router.

  3. Make sure the print server is broadcasting the printer. On your print server, open "Printers" and find the "Server" menu. Click on "Settings" and make sure "Publish shared printers connected to this system" is checked, nothing else should need to be checked. (You may need to click "Show printers shared by other systems" on the Ubuntu client for it to see the shared printer.)

share|improve this answer
    
Thank you for your answer but I am afraid that the Ubuntu Machine connected to the printer and Windows cannot see each other. Also when I search for network printer nothings comes up. The Ubuntu printer seems to be shared because the box next to it is ticked but when I untick and re-tick the box it gives the following message Shared printers are not avialable to other people unless the "Publish Shared Printer option" is enabled in the server settings How would I enable this option? –  Jakub Jan 20 '13 at 11:20
    
To fix the prompt: In "Printers", go to the "Server" menu and click "Settings". Then, check the box next to "Publish Shared Printers". –  Shauna Jan 20 '13 at 16:34
    
See my edit for more. –  Shauna Jan 20 '13 at 16:44
    
Can you update this for the latest version of Ubuntu? –  Seth Mar 5 at 3:29
    
@Seth - The question is specifically for 12.04, I think it'd be better to keep the answer that way (especially since 12.04 is still supported and doesn't EOL until 2017). Additionally, I no longer run Ubuntu, but I'm pretty certain the process is still pretty much the same. The only difference might be details like menu item names. –  Shauna Mar 5 at 21:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.