Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Mame via SDLmame but have so far failed to successfully install any decent GUI that enables categorisation of games, favouriting, or preview screenshots. I have many hundreds of ROMs.

  • Gnome Video Arcade will not read my ROMs from an external hard drive, even when they have been configured correctly in ~/.mame/mame.ini

  • Lightning looks interesting but crashes when trying to build a database of my ROMS

  • QMC2 fails to install due to missing dependencies
  • GMameUI also fails to install on Ubuntu 12.10

Any guidance appreciated! Thanks

share|improve this question
GMameUI fails probably because its last version is from 2009, and it wasn't ported to GTK3. It was removed from the 12.04 repositories, and probably never made it to 12.10. – MestreLion Feb 20 '14 at 8:53

I've tried Gnome Video Arcade, and it also didn't list any ROMs. After investigating, it turned out that one of my ROMs was corrupted, and that prevented GVA from showing any ROMs at all!

So, care to do a little test?

  • Backup your current MAME config/rom folder:

    mv ~/.mame ~/.mame.bak
  • Recreate it with default settings:

    mkdir ~/.mame/roms
  • Copy a single game to the default roms folder, and test it with no launcher:

    cp /path/to/roms/for/example/ ~/.mame/roms
    mame rastan

If that works, great!

Now delete (or backup) the GVA database so it is re-created from scratch, and test it:

    rm -rf ~/.local/share/gnome-video-arcade

I did this, and it worked nice. Then it was a matter of finding and deleting th offending ROMs and rebuild my MAME settings.

share|improve this answer

The new GNOME Games app is a frontend for many games.

Unfortunately, it's not been packaged for Debian or Ubuntu yet.

share|improve this answer

Here is a workaround to avoid Lightning MAME Frontend (lightningmf) crashes when building database.

Into the mame.ini file, you must set the "numprocessors" entry with a numeric (integer) value, not "auto" as it set by default.


The script /usr/share/pyshared/lightningmf_pk/ generates following error when building database because of a badly formatted XML file created in /tmp:

File "/usr/lib/pymodules/python2.7/lightningmf_pk/", line 213, in parse_elements
event, root =
File "/usr/lib/python2.7/xml/etree/", line 1266, in next raise e
xml.etree.ElementTree.ParseError: syntax error: line 1, column 0

The temporary XML file starts with those two lines who make the parser confused:

While parsing $HOME/.mame/mame.ini:
Illegal integer value for numprocessors: "auto"; reverting to auto
share|improve this answer

I am playing MAMEUI 32 0.146 fluently with a old Laptop C500 ( Pentium M ) emulating the windows ver. with wine. :) the roms work better than linux mame for me snap shot of neogeo game

wine runs win mame

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.