Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ubuntu is 12.04LTS

I was used apt-get to install opera and cowsay. I've tried to execute them, but they all said

ubuntu@ubuntu:~$ cowsay
bash: /usr/games/cowsay: Permission denied
ubuntu@ubuntu:~$ opera-next
bash: /usr/bin/opera-next: Permission denied

I've already tried chmod a+x them but they won't work

Here is mount output

ubuntu@ubuntu:~$ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=1017476k,nr_inodes=214672,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,relatime,size=410052k,mode=755)
/dev/sdb1 on /cdrom type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /rofs type squashfs (ro,noatime)
/cow on / type overlayfs (rw,relatime,lowerdir=//filesystem.squashfs,upperdir=/cow)
none on /sys/fs/fuse/connections type fusectl (rw,relatime)
none on /sys/kernel/debug type debugfs (rw,relatime)
none on /sys/kernel/security type securityfs (rw,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,relatime)
none on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
none on /run/shm type tmpfs (rw,nosuid,nodev,relatime)
/.filesystems/usr/usr.sqfs on /.filesystems/usr/squash type squashfs (ro,relatime)
aufs on /usr type aufs (rw,relatime,si=f8757c62)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=999,group_id=999)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=0,group_id=0)

And ls -l of these 2 file

ubuntu@ubuntu:~$ ls -l /usr/games/cowsay
-rwxr-xr-x 1 root root 4421 Dec 22  2010 /usr/games/cowsay
ubuntu@ubuntu:~$ ls -l /usr/bin/opera-next
-rwxr-xr-x 1 root root 169 Jan 17 22:44 /usr/bin/opera-next

And cat of those file

http://pastebin.com/FP3MiQ6t (They are to long so I post them here)

share|improve this question
    
Could you show us a "ls -l" from these two files? –  jap1968 Jan 19 '13 at 13:40
    
@jap1968 ls -l info added –  Arch user Jan 19 '13 at 13:43
    
are these scripts launching other commands? I mean, can you use "cat" to see their contents or they are compiled executable files? –  jap1968 Jan 19 '13 at 13:45
    
Does this work: /lib/ld-linux.so.2 /usr/games/cowsay –  Dennis Kaarsemaker Jan 19 '13 at 13:45
    
@jap1968: cowsay is perl scripts and opera-next is a shell scripts. –  Arch user Jan 19 '13 at 13:49
show 5 more comments

2 Answers 2

well actually its not going to work in that way.

you need to enter that file name.actually cowsay can have arguments.

for example loot at the image I have attached

enter image description here

And I think you'd better move with its man-page.

Cowsay generates an ASCII picture of a cow saying something provided by the user. If run with no arguments, it accepts standard input, word- wraps the message given at about 40 columns, and prints the cow saying the given message on standard output.

share|improve this answer
add comment
up vote 0 down vote accepted

It's beacuse of aufs mount of /usr I've used squashfs /usr speedup method. I was fixed it by change fstab aufs entry like this

overlayfs /usr overlayfs noatime,nodiratime,lowerdir=//.filesystems/usr/squash,upperdir=/.filesystems/usr/overlay

Hope this help with anybody face my problem

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.