Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to Ubuntu and Linux and I want to install and use the newest version of the screenwriting software Celtx on Ubuntu 12.04 LTS.

After trying and using

sudo add-apt-repository ppa:dreamstudio/video
sudo apt-get update
sudo apt-get install celtx

I unfortunately had to find out that was a rather old version with a fairly screwed up UI. I then downloaded the newest version from but now I don't know how to properly install it.

I extracted it to /home/username/ (there was no ~/bin/) as described here and I can now launch the application by running the file celtx within that folder (I get asked whether I want to Display, run or run it in Terminal) and it works fine. But I can't get it to launch from Unity.

I tried right-clicking the launcher button and going "Lock to Launcher" while it's running and it does create an icon but clicking it to launch the program does nothing. Also searching for celtx in the Dash doesn't find the app.

And advice on how to properly install Celtx 2.9.7 in Ubuntu 12.04 LTS?

share|improve this question
to lock to unity you can use this… – Raja Jan 19 '13 at 14:07
Was having the same trouble and this pretty much fixed it. Its more of a patch than an install but I'm having no problems with it on ChrUbuntu. Hope that works! – user160665 May 21 '13 at 19:23
This is untested, but I found a link that describes how to do it. I'm going to try it myself in a little bit. – Manuel Sep 16 '13 at 4:58

This tutorial: How to Install Celtx 2.9.7 on Ubuntu Linux might help people in the future, as I found it very brief and clear. Just pay attention to your download path: If your Celtx install archive is not in the default Downloads folder, type it in manually.

  1. Press Ctrl+Alt+T to open the terminal, then run the below commands one by one to extract to /usr/local/:

    tar xjf ~/Downloads/Celtx-*.tar.bz2
    sudo mv ~/celtx/ /usr/local/
  2. Now create a shortcut launcher for Celtx:

    Install required package:

     sudo apt-get install gnome-panel --no-install-recommends

    Run this command to create a launcher for Celtx:

    sudo gnome-desktop-item-edit /usr/share/applications/ --create-new

    Select icon from /usr/local/celtx/icons/ folder. Type /usr/local/celtx/celtx in command area.

Now you can search for and open celtx in the Unity Dash.

share|improve this answer

Using your terminal, just put the extracted celtx folder in /usr/lib. You may need root permission. So go to where you extracted the folder and just type

sudo mv celtx /usr/lib

Then, cd to /usr/lib/celtx. Type ./celtx and it will launch.

You can create a launcher to do it in the future. Just remember that most program folders, when you look inside and see a bunch of files ending in .so or whatever, go into /usr/lib.

share|improve this answer

protected by Eric Carvalho Nov 29 '14 at 16:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.