Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know when I first installed the OS it said I needed to install additional drivers. It installed Broadcom B43 legacy driver. Following what I saw in a message board I went into Synaptic and installed bcmwl-kernal-source or whatever. I went into terminal and tried installing the rfkill thing and typing rfkill unblock all - which also didn't work. I don't know what to do.

When I click on the wireless image it just says in the drop down menu Wired network disconnected. When I right click on it it says in the drop down menu Enable Networking, but it's greyed out, and Enable Notifications which is checked off.

The laptop I'm using is a Dell Latitude D600, if that helps.

share|improve this question
    
What was the reason you followed someone's instructions on a message board? Did it work after just installing the drivers and rebooting? –  Stefano Palazzo Feb 3 '11 at 23:44

2 Answers 2

Normally Broadcom wireless drivers are restricted in ubuntu. You can install it using the additional driver utility. System->Administration->Additional Drivers.

Just active your driver in that application.

share|improve this answer

In addition to Abhijeet's answer, you can also use your wired connection to try installing the B43 firmware using this command :

sudo apt-get install firmware-b43-installer

After running this command in a terminal (run one from your Applications/Accessories menu), you should find your wireless adapter is working. It didn't need a reboot in my case, but your mileage may vary.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.