Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Bit stuck here.

I have 2 machines that cannot resolve LAN hostsnames, unless there are specific entries in /etc/hosts

But other machines on the LAN can resolves hostnames.

My LAN:

  • 1 x Cisco router runnning DD-WRT v24-sp2 with DNSMasq enabled. I've configured this with the hostnames and IPs on my LAN.
  • 1 x Kubuntu 12.10 (resolves all hostnames correctly as long as they are entered into DNSMasq on the router)
  • 2 x NAS (also resolve all names correctly)

  • 1 x Ubuntu Server 12.04 (this does NOT resolve local hostnames unless they are entered into /etc/hosts)

  • 1 x XBMCLive (Dharma) (same - does not resolve unless entries are in /etc/hosts)

How do I get the last 2 to use the DNSMasq entries on the router? Each machine is set to use the router as a nameserver, and all units resolve external addresses correctly.

Thanks.

some more info:

whilst on server, if I ping another PC (wstation)

$ ping wstation
PING wstation.local.domain (x.x.x.x) 

If I then append .local

$ ping wstation.local
PING wstation.local.local.domain (x.x.x.x)

and directly

$ ping 10.0.0.4
PING 10.0.0.4 (10.0.0.4) 56(84) bytes of data.
64 bytes from 10.0.0.4: icmp_req=1 ttl=64 time=0.387 ms
64 bytes from 10.0.0.4: icmp_req=2 ttl=64 time=0.316 ms
64 bytes from 10.0.0.4: icmp_req=3 ttl=64 time=0.312 ms
64 bytes from 10.0.0.4: icmp_req=4 ttl=64 time=0.280 ms
64 bytes from 10.0.0.4: icmp_req=5 ttl=64 time=0.322 ms
^C
--- 10.0.0.4 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3998ms
rtt min/avg/max/mdev = 0.280/0.323/0.387/0.038 ms                                                                       
share|improve this question
    
I don't know the answer, and I have no idea if this will be helpful, but in case you didn't know... I discovered that if I appended ".local" after a machine name, it would somehow be found without any configuration needed. It actually helped me because I was specifying addresses, but was needing to keep changing entries when I would add or remove an OS I used for testing, etc. But, by specifying machinename.local, I no longer needed to worry. If you know where this comes from, feel free to tell me. :) –  Marty Fried Jan 19 '13 at 1:32
1  
Hi Marty, thanks for your answer. I've added some more info to the problem to show what happens with .local –  teracow Jan 19 '13 at 21:01
add comment

1 Answer

up vote 3 down vote accepted

About your current output

ping wstation
PING wstation.local.domain

Clearly indicates that your pc is appending .local.domain to non-FQDN queries. This is something configured improperly or at least wrong in your set up. (unless you actually use the .local.domain suffix on purpose)

Name resolving and periods

One important thing what a lot of people don't know, is that a full name should always end with a period (.). If you omit it, then the machine will try to resolve it within the local search domain (e.g. mydomain.tld). So in that case, a query for mypc.local would become mypc.local.mydomain.tld. To prevent this, query with the period.

Resolver configuration

The resolver configuration is of great importance here. In Ubuntu (and Debian) this is configured in the file /etc/network/interfaces (assuming you're not running NetworkManager):

iface eth0 inet static
   address 192.168.3.3
   netmask 255.255.255.0
   gateway 192.168.3.1
   dns-nameservers 192.168.3.45 192.168.8.10
   dns-search foo.org bar.com                      # <-- these are the search domains

Name resolving in Linux can also be accomplished in other ways. It's not just that the local DNS server is being queried for all of this. Take a look at your /etc/nsswitch.conf file for the hosts configuration of resolving:

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

This means that files are tried first (this is the /etc/hosts file), then mDNS and only later the real DNS server is queried. mDNS is implemented using Avahi in Linux and is called Bonjour on Apple devices. It is using the .local suffix by default and works via broadcast messages. Much like ARP works, but then for DNS.

All these systems can be very confusing and even more when using .local in a regular DNS setup mixed with mDNS devices. I guess this is why you're confused now as to why one device works and the other doesn't: they're not all using the same resolving method.

To sort things out

  • Avoid the use if .local unless you want to rely on mDNS completely. From your question I understand you'd like to keep things configured yourself in a central place, so my approach here is to avoid it.
  • Configure your local DNS server (the DD-WRT device in your case) to use a special domain name, e.g. my.home. For dnsmasq this is a single setting, but in regular setups this should be configured on both the DNS server as well as the DHCP server (as it's being announced via DHCP).
  • Configure all PCs to have a simple and unique host name. They use this in their request for DHCP and this is used in the dnsmasq running on your router to resolve them. Alternatively, configure them manually to not to have to rely on DHCP.
  • Remove any leftover configuration in /etc/resolv.conf in case you fiddled with it in the past.
  • Configure the PCs in your network to use my.home as the local search domain. This can be done via DHCP automatically, or if using static addresses via the /etc/network/interfaces file or in Network Manager:

    enter image description here

  • Now both simple name resolving (ping hostname) as well as full name (ping hostname.my.home) should work.
share|improve this answer
2  
Wow! Awesome answer gertvdijk! Very comprehensive. So much so, that I'll need some time to understand what you've said. I can say that I tested a ping with a dot after the hostname and it worked correctly. I don't use DHCP on this LAN for the permanent machines. I've never configured the .local settings on any machine as I didn't understand what it was all about. I'll investigate this further as per your instructions and get back to you. –  teracow Jan 19 '13 at 23:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.