Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After last night's kernel upgrade I'm getting the following symptoms:

After restarting computer several times.

  • One of my screens (always the same one) is split down the middle. Not always in the same place, and sometimes shows "trails".

  • Unity desktop half-loads and then doesn't respond to any command. The mouse moves but nothing is clickable.

  • Xmonad desktop responds (I'm on Xmonad desktop right now, using the second screen).

Curiously:

  • During one of my boots, Ubuntu brought up the Grub menu. I chose "ubuntu" option and suddenly everything worked fine. I restarted the computer again, and everything is screwy again.

  • I've tried to bring up the Grub menu again, but pressing shift during boot process makes my computer shut off instantly and restart.

How do I revert the damage caused by the dist-upgrade?

share|improve this question

closed as too localized by Jorge Castro, hhlp, Tom Brossman, Ringtail, Flimm Jan 19 '13 at 21:04

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Do you have an ATI or nVidia graphic card? What model? Have you installed some driver? –  Lucio Jan 19 '13 at 1:12
    
kernel update was the problem. I apt-get autoremoved it and it's back to normal. -- To skip a kernel version, I just have to wait till the next kernel upgrade and apt-get dist-upgrade then, right? –  o_o_o-- Jan 19 '13 at 1:22
1  
First: Don't put the answer into the question, you should answer your own question. Second: If you do an apt-get dist-upgrade then your kernel version will be updated. If you want to keep a specific version you can remove the new one, just like you did. –  Lucio Jan 19 '13 at 2:47
    
@Lucio fixed. thanks. –  o_o_o-- Jan 19 '13 at 3:34
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Flimm Jan 19 '13 at 21:04
add comment

1 Answer 1

up vote 1 down vote accepted

Solution for future reference:

Kernel update was the problem. Removing the newly updated kernel solved the problem:

sudo apt-get autoremove linux-image-3.5.0-22.generic
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.