Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well I just upgraded Ubuntu 11.10 to Ubuntu 12.04 LTS and surprisingly enough I cannot login because the password is not correct. I realized that the reason is that the keyboard layout is Farsi and therefore it does not accept it. Farsi layout was my third choice of layout in Ubuntu 11.10 but now it is the only choice.

What are the options to bypass this issue?

share|improve this question
    
I think that the main issue is that you can't see what are you writing, isn't? I mean, if you have special characters in the password.. Also, what keyboard (model) are you using? –  Lucio Jan 19 '13 at 0:37
    
The problem is that Farsi keyboard has close to Arabic words and my password needs a combination of Latin words and numbers. At the same time, the keyboard layout shows only one option "Farsi" but it was supposed to show two layouts "Swedish" and "Farsi". –  poet in morning Jan 19 '13 at 10:56
    
Question is probably a duplicate of this one: askubuntu.com/q/244961/122014 you asked just before. Did you try to press the combination of buttons to change keyboard language on login screen suggested in that answer? For me that answer worked very well (with different languages, also non-latin characters, but same problem). –  diamy27 Jan 21 '13 at 18:07

1 Answer 1

Are you able to login on constole instead of gui? (ctrl+alt+F2) than try to type

sudo apt-get install $(check-language-support -l sv)
sudo dpkg-reconfigure locales

And read this carefully http://askubuntu.com/a/149884/122014

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.