Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried everything I have read about this. The problem is I can't find out what card it is. The only thing that comes up is Realtek Semiconductor Corporation. There are no name on the card. No resctricted drivers shows up.

I have tried the solutions here and from other sites. When I tried them, I get error 1 and 2.

I have managed to install the wired network, by using the suggestions found here. But every solution for wireless fails with the errors 1 and 2.

Can anyone please help me?

Here is the output of sudo lshw -C net:

*-network UNCLAIMED     
   description: Ethernet controller
   product: AR8162 Fast Ethernet
   vendor: Atheros Communications Inc.
   physical id: 0
   bus info: pci@0000:01:00.0
   version: 10
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi msix bus_master cap_list
   configuration: latency=0
   resources: memory:f0100000-f013ffff ioport:3000(size=128)
  *-network UNCLAIMED
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: ioport:2000(size=256) memory:f0000000-f0003fff

And here is the reason for the error 2, I have to search to find out which one gave me error 1:

make -C /lib/modules/3.5.0-22-generic/build M=/home/kenneth/Nedlastinger/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012 modules
make[1]: Entering directory `/usr/src/linux-headers-3.5.0-22-generic'
CC [M]  /home/kenneth/Nedlastinger/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o
/home/kenneth/Nedlastinger/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c: In function ‘_rtl_init_mac80211’:
/home/kenneth/Nedlastinger/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6: error: ‘IEEE80211_HW_BEACON_FILTER’ undeclared (first use in this function)
/home/kenneth/Nedlastinger/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.c:320:6: note: each undeclared identifier is reported only once for each function it appears in make[2]: *** [/home/kenneth/Nedlastinger/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012/base.o] Error 1
make[1]: *** [_module_/home/kenneth/Nedlastinger/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-22-generic'
make: *** [all] Error 2

I have found out that the wireless card is called rtl8723ae.

When I looked at the homepage for toshiba, then I found that this laptop is delivered with ubuntu or windows 8. So it is a mystery that it wont work. The one with ubuntu was not available in my country.

I see from other posts that it should work in 12.04. Do I have to downgrade from 12.10 to 12.04? This is where I found that information: Drivers for Realtek wireless module for Toshiba C850-A965?

share|improve this question
    
@guntbert I have updated my first post. –  user66987 Jan 19 '13 at 18:44
    
As far as I see it, there is only one real error: the compiler complains about an undeclared identifier in line 320 of /home/kenneth/Nedlastinger/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2‌​012/base.c. That means that there is something wrong within the c-code of that module - maybe some #include ?? –  guntbert Jan 20 '13 at 12:08
    
I don't know. Really, I don't understand any of the things I added to the question. That is why I asked for help. –  user66987 Jan 20 '13 at 13:07

1 Answer 1

You should use the later version of the driver tarball named: rtl_92ce_92se_92de_8723ae_linux_mac80211_0007.0809.2012

That should fix the compile error. After the make completes, run

 sudo make install

and then check that the two rtl8723...bin firmware files got copied to /lib/firmware/rtlwifi Do it yourself (files are in the tarball/firmware directory) use sudo cp to copy them.

Better yet, use 13.04, that comes with working wireless and ethernet.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.