Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been trying to catch up with some of the old games from way back that are about right for my little Aspire One netbook through Wine.

I've run into a problem Baldurs Gate, however, which is that I can't change CD.

Obviously, I don't have a CD drive, so I have copied the CD content onto an external hard drive and I'm using a mount command with the loopback option to persuade the game that the CD is present. This allowed installation to work correctly and works fine to run it and to play the content from the first CD. However, when the game asks for CD2, I'm stuck.

If I mount the CD2 ISO to the CD Rom path it doesn't appear to respond, whether or not I have first unmounted CD1. When I ask Wine to show me the CD drive it contains the right data, but it seems as though whatever signal would be interpreted by Windows to mean the CD drive has been closed isn't being sent.

Does anyone know of a way to do this, or am I barking up the wrong tree and there is something else I need to do?

share|improve this question
any luck with these solutions? – belacqua Feb 15 '11 at 4:17
The tutorial looks like it should work, but I haven't actually managed to make it work yet. – glenatron Feb 15 '11 at 7:57

I can't test it right now, but I think you need to use the wine eject command (

share|improve this answer
Thanks! I'll try it later and let you know! – glenatron Feb 2 '11 at 17:45
I get a message "Cannot open device for drive e:" - apparently this is a feature in wine, although I couldn't quite follow why. – glenatron Feb 2 '11 at 21:49
I wonder if this is because I have to use sudo to mount the drive, but if I run wine as superuser it complains because that's not the current user profile. – glenatron Feb 2 '11 at 22:30

There's a tutorial that covers this here:

You might try the solution at the bottom of the page first ("AnotherAlternativeToInstall"), as it seems to require fewer steps.

There are also specific things people did to install and run in the entries at winehq for Baldur's Gate.

share|improve this answer

I found this thread because I was having the same issue. This may not work for everyone, but it did for me. (I made a folder in home called /virtualdrive/Drive0) Also, I had the problem with a different game, but I think it applies.

Mount iso # 1

sudo mount -o loop AOMG_D1.iso ~/virtualdrive/Drive0

Run game installer, hit install. It loads to 32% or something, then asks for iso # 2. Don't try to eject or unmount first iso, just use the same command to mount iso # 2. I think this creates a random drive letter and automatically maps the mount path in wine.

Mount iso # 2

sudo mount -o loop AOMG_D2.iso ~/virtualdrive/Drive0

You should wait 5-10 seconds at this point, and it should continue the installation. If not, try pressing "OK" to the prompt about inserting next disc.

I was actually QUITE surprised this worked.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.