Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have searched for a solution to my problem but I just get people who have issues who can't resolve any of their workplace names.

My issue is I can't resolve ONE of my workplace servers. I have the VPN setup through Network Manager and everything seems just fine. I can connect to most of the machines and servers at work. Anything that is company.local or company.localnet resolves fine.

However for some reason my company has an additional nameserver company.test setup. When I am connecting to the VPN through my Mac (trying to get rid of it) it sets up the DNS fine. It uses the same nameservers as everything else.

But when my Ubuntu connects I can not resolve company.test and I don't know how to add it manually or configure Ubuntu to find it.

I have added company.test to the VPNs "additional search domains" but no avail.

How can I manually add a single DNS entry to a VPN connection or how can I configure Ubuntu to pick up this company.test search domain.

Thanks Corey

share|improve this question

1 Answer 1

You have two options.

First, add the DNS entry to the VPN connection. When you setup the connection (sorry but there are about 100 ways to do this) look for a place to put DNS entries, name servers, or the like, and enter the IP of the DNS server for the company.test domain. If all else fails you can add the IP for the DNS server to /etc/resolv.conf (after the DNS connection is running).

Or, if your just trying to find a single machine at say puter.company.test then you can just add that line to /etc/hosts

it should look something like

10.10.10.10 puter.company.test

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.