Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For testing purposes I installed Natty. During the installation I chose to install it next to my "safe" installation of 10.10.

This installation also still seems to be there, but I can not manage to boot it from GRUB anymore. It is simply not shown. Booting Natty works like charm, though.

How do I get it to appear again, so I can boot that installation?

sudo update-grub output

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.38-1-generic
Found initrd image: /boot/initrd.img-2.6.38-1-generic
Found linux image: /boot/vmlinuz-2.6.37-12-generic
Found initrd image: /boot/initrd.img-2.6.37-12-generic
Found memtest86+ image: /boot/memtest86+.bin
done
share|improve this question

2 Answers 2

up vote 0 down vote accepted

Even I had the same problem. You know how I fixed it? Yes, a painful method - By Hand.

Let me explain you how I did it. I needed to add this entry to /boot/grub/grub.cfg

Take a backup of the file before you go ahead

menuentry 'Ubuntu, with Linux 2.6.35-25-generic' --class ubuntu --class gnu-linux --> class gnu --class os {

recordfail

insmod part_msdos

insmod reiserfs

set root='(hd0,msdos7)'

search --no-floppy --fs-uuid --set ada5fcfd-84b7-4ffa-9c52-db45d17518a7

linux   /boot/vmlinuz-2.6.35-25-generic root=UUID=ada5fcfd-84b7-4ffa-9c52-db45d17518a7 ro   quiet splash
initrd  /boot/initrd.img-2.6.35-25-generic

}

The menuentry name can be 'Ubuntu, with Linux 2.6.35-25-generic' or whatever you choose to be.

Change the set root='(hd0,msdos7)' to set root='(hd0,msdosx)' and x represents the partition no of the drive

insmod reiserfs can be changed to insmod ext4 or the filesystem you choose (info from the links which I googled up just now). Since I have all my / parititons as reiserfs so I did not need to change this.

ada5fcfd-84b7-4ffa-9c52-db45d17518a7 in the last two lines can be replaced by the partition UUID. You can get the partition UUID by running the command

ls -l /dev/disk/by-uuid

/boot/vmlinuz-2.6.35-25-generic is a file contained in the /boot folder in the parition where your ubuntu is installed. Yours can be a different version number. The file should start with vmlinuz

Just like /boot/vmlinuz-2.6.35-25-generic same goes for /boot/initrd.img-2.6.35-25-generic

After booting and selecting this option, I found that there was an error. Leaving it for a few seconds made it continue and I am now typing from the installation entry I added in grub list.

Footnote: GRUB2 is still a mystery. Grub Legacy had easier config files

share|improve this answer

Have you tried running "sudo update-grub" to see if it detects the other system?

share|improve this answer
    
Yap, did that, did not help. It only displays the images as shown during boot as well. –  Ingo Feb 2 '11 at 15:45
    
Well, you can try something else. Download the "Super Grub2 Disk" (supergrubdisk.org) –  nejode Feb 2 '11 at 21:53
    
Download the "Super Grub2 Disk" (supergrubdisk.org). Boot from it, let it find your existing systems and log into your 10.10 install. From within the Maverick environment run update-grub again to see if it finds the 11.04 kernels, if it does, then run sudo grub-install /dev/sdx to use Maverick's grub2. If it doesn't find Natty... well, at least you have your "safe" 10.10 back! Another cuestion: when you boot into 11.04, can you "see" the 10.10 filesystem? It's a good idea to run sudo fdisk -l just to be sure you didn't overwrite your 10.10 –  nejode Feb 2 '11 at 22:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.