Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a lot of Powerpoint slides that I converted to LibreOffice Impress. The resulting hyperlinks are very faded, very hard to see. I can't seem to find any way to change the colour of hyperlinks as a whole.

Any colour change I do make on an individual url link does not hold when converted back to .ppt which is sometimes necessary.

I have tried the tools=options=libreoffice=appearance route but it only seems to affect the very first hyperlink in the slide set

share|improve this question

3 Answers 3

Go to Tools, then choose Options. From there, a window should pop up and one of the selections is Appearance under the LibreOffice tab. A checkbox displaying the colours for a visited or unvisited link can be changed. Good luck!

share|improve this answer

There are two places which control the internet or index link color -- see image:

  1. Tools > Options > APPEARANCE > Unvisited Links, Visited Links
  2. Format > Styles and Formatting > Character Styles ("a in box" icon) > Index Link, Internet Link

My document is using Index Links which were blue and which I wanted to be black. I changed the Index Link character style to be Black but only some of them changed. Then I found the Appearance controls under Tools>Options and by turning the Links colors off it worked.

http://nsol.altervista.org/alterpages/loofficechangelinkcolor.png#gallery

share|improve this answer

Styles and Formatting window

https://help.libreoffice.org/Common/Editing_Hyperlinks

Change the attribute of all hyperlinks

Open the Styles and Formatting window.

Click the Character Styles icon.

Right-click the "Internet Link" or "Visited Internet Link" character style, and choose Modify.

In the dialog, select the new attributes, and click OK.

Notes

  • Character Styles icon = button on top of the styles and formatting window

    Character Styles icon in Libreoffice

  • Changes should be made to "Hyperlink" too (if you used or converted from a Microsoft Office Word document).

  • In order to make changes to a text, select the text you want to change and double-click (left-click) on a character style (e.g. "Hyperlink").
share|improve this answer
1  
in my libreoffice draw (v3.5.4.2) there's no "Character Styles" icon at all... :( –  Attila Lendvai Nov 7 '13 at 18:08
    
@AttilaLendvai libreoffice draw is a drawing program, it doesn't have to do with writing, therefore I think that character styles doesn't exist for draw. Also, you could try the new 4.1.x versions. If you use ubuntu 12.04 you can try using this ppa: launchpad.net/~libreoffice/+archive/libreoffice-4-1 –  medigeek Nov 7 '13 at 23:41
    
it's a drawing program, but it has textboxes, which i would expect to behave the same as writing text in Writer. but it's not an urgent issue for me, so i'll just wait an check the next time i need it... –  Attila Lendvai Nov 27 '13 at 8:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.