Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using Ubuntu 12.04 with Gnome3 for a while, than started back on Unity.

My problem is that the super button only opens the Dash when there are already a few windows in a workspace. When the workspace is empty (there are no windows on that workspace), the only way to open the dash is clicking on the ubuntu icon in the launcher.

Is this the expected behavior or do I have some problem?


SOLUTION

The problem was caused because I had turned off the Desktop handling by nautilus. So, it seems that this shortcut only runs when there's at least the nautilus Desktop or something else running on that workspace.

It looks like a buggy feature to me. I'll post a bug issue later on when I confirm how to reproduce it, and see what people from the dev team say about it.

share|improve this question
    
Hi, @TomBrossman and others. I don't want to create a fuss about it, buy I just wanted to ask why do you think the question is off topic. I asked about a problem I had with Ubuntu and its standard stack of softwares (unity, nautilus). I understand that given I'm a newcomer to this SE-site I might have overlooked some rule. Could you please point out what's wrong with the question so that I may avoid this in future questions? Thanks. –  Rafael S. Calsaverini Jan 21 '13 at 16:26
add comment

closed as off topic by Tom Brossman, qbi, Eric Carvalho, Ringtail, Eliah Kagan Jan 20 '13 at 9:02

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 5 down vote accepted

Super (the 'Win' key) opens Dash from empty desktops on my system (12.10) by default.

I can, however, reproduce your situation if I use the gnome-tweak-tool to set Desktop > Have file manager handle desktop to Off. Check this setting on your system.

You may have changed something that interacts with this while using Gnome. If it is already set to On, set it to Off and back to On again to force an update through.

share|improve this answer
    
Yes, it was it. I had set off nautilus handling of the desktop. But it's still weird though. It looks like a buggy feature to me. I'll post a bug issue later. –  Rafael S. Calsaverini Jan 19 '13 at 22:34
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.