Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

LXPanel 0.5.11 that is default in Lubuntu Quantal has enhanced features compared to the older version that is default in Lubuntu Precise (0.5.8).

The new version of LXPanel is available for Precise. But while installing that in Precise 12.04, it asks for libmenu-cache2 (that seems available only for Raring 13.04).

Installing that libmenu-cache2 in Precise would allow installing LXPanel 0.5.11 (for Precise). (But is it safe to install this libmenu-cache2 for Raring in 12.04? should it replace libmenu-cache1 there? it does not by default.)

The odd thing is that in a different computer with Lubuntu Quantal I see that LXPanel 0.5.11 works with only libmenu-cache1.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The problem is with the way the version of a build (especially dev version) is displayed.

In Lubuntu Quantal, the LXPanel version that works with only libmenu-cache1 is displayed as

enter image description here

But in Synaptic Manager it's 0.5.10:

enter image description here

Also,

~$ apt-cache policy lxpanel
lxpanel:
  Installed: 0.5.10+git20120823-0ubuntu1
  Candidate: 0.5.10+git20120823-0ubuntu1
  Version table:
 *** 0.5.10+git20120823-0ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ quantal/universe i386 Packages
        100 /var/lib/dpkg/status

I do not know how Launchpad displayed the name of this version, but it could be a dev or otherwise improved version of 0.5.10, although I do not remember manually updating LXPanel in Quantal.

Also, after installing (in Lubuntu Precise) LXPanel for Precise from here, which looks like being a daily build of 0.5.11 (Launchpad named it lxpanel-dev-0.5.11~bzr1306+201301150740~precise1) (which was possible only after installing libmenu-cache2 for Raring from here) I see that LXPanel "About" says version 0.5.12, while in Synaptic it was displayed 0.5.11.

So, the dev version installed in Precise is not the same version as the one from the other computer running Quantal, but a newer build that asks for libmenu-cache2, while that quantal version does not.


It seems that LXPanel versions above 0.5.10 need libmenu-cache2.

(But to see the real version of a build one must look in Synaptic or run apt-cache policy lxpanel, because dev builds might show a newer version in "About" section.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.