Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Why does GNOME panel open up when I launch UNITY 2D instead of Unity panel? This I am starting to see from last 2 days, any idea how to fix this?

share|improve this question
    
I only see it when I run the command gnome-panel at the command prompt. So I think you need to make sure that gnome-panel isn't running. –  jrg Feb 2 '11 at 13:59

2 Answers 2

up vote 2 down vote accepted

Well finally solved, I needed to do the following

  1. gnome-panel --replace
  2. unity-2d-launcher &
  3. Save the session and logout
share|improve this answer

What's likely happening is that gnome-panel is set to run on login, and as such it'll automatically start every time you log into GNOME. So, what you can do is to open up Startup Application Preferences (AKA gnome-session-properties), and check for something that has a you don't know what it is, then you want "Edit" that item, and see what comes up.

Example.

Keep going through the list until you find the gnome-panel command tucked away somewhere.

share|improve this answer
    
I don't have gnome-panel set to run at startup, this is the first thing I verified. Not sure why this issue is coming. Is there a way to kill gnome-panel I tried kill but it kept restarting. –  Madhava Feb 2 '11 at 14:34
    
Hmm. I'd run killall gnome-panel - that worked for me once I started it. –  jrg Feb 2 '11 at 14:35
    
No matter how many times I execute killall gnome-panel even with sudo as well it still keeps coming again and again :( –  Madhava Feb 2 '11 at 14:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.