Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I hide CIFS volumes in the Places menu?

On Ubuntu 10.10, I added a CIFS network share into /etc/fstab using /media/pub as my mount point. The share becomes visible on the Desktop and under Places (drive icon), which is what I want. But the problem is, Ubuntu 10.10 (unlike 10.04) creates another entry under Places with same name "pub", except this appears to be a mount shortcut rather than another link to the share. When I move my mouse over it says "Mount pub" and if I click on it, it will mount the share and again each time (if already mounted) - it does not display contents of share. In either case, an error pops up soon after "Unable to mount pub - Timeout waiting for mount to appear".

The share itself is accessible, but I can't unmount via GUI, system reports its mounted multiple times and I have to unmount via terminal sudo umount -a.
As I'm mounting the share at boot time, I don't need this manual option under Places. Is there an easy way to stop Ubuntu from listing it under Places?

I have tried making the mount point under /mnt, this fixes the problem, except creates another as it removes the drive icon from Desktop and Places. I could create a bookmark, but just wondered if there's an easy fix to this unwanted entry under Places.

Thanks

share|improve this question

marked as duplicate by Stefano Palazzo, Jorge Castro, Marco Ceppi Feb 3 '11 at 14:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I came across this post before I posted my question. Don't believe the situation is the same. The two duplicate icons under my Places menu, behave very differently to each other. –  user10085 Feb 3 '11 at 10:28

1 Answer 1

you must have using wrong mount command to auto mount the partition. I was facing the similar issue and resolved by using a small utility called : "Storage Device manager". You can install it from "Ubuntu Software Center". Remove any mount option you have added in the /etc/fstab and use that utility to auto-mount the partitions.

This will Definitely resolve your problem...

share|improve this answer
    
Thanks, I will give this a try. In the meantime have solved this for the moment, by adding the mount point under /mnt instead. It does not have the annoying mount icon in Places menu. I have created a bookmark and a shortcut on Desktop for access to the share. –  user10085 Feb 3 '11 at 10:25