Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 LTS version on my HP Pavilion G6 2006AX laptop. This is the only operating system that I have on my laptop (no dual boot).

Processor & Graphics detail: AMD A6-4400M APU with Radeon(tm) HD Graphics × 2

I installed AMD catalyst 12.11 beta11 driver to support the Graphics card. Seems like it is doing OK.

Unfortunately, I am not able to configure my audio drivers and it just shows up as speaker icon with a dash dash dash next to it.

Is there anyway that I can help you troubleshoot this issue? (like config, logs etc.) I am sure other HP Pavilion G6 users might have faced this...I am unable to find a solution after searching Ask Ubuntu forums.

running alsamixer on commandline...provides the following info:

Card: HD-Audio Generic
Chip: ATI R6xx HDMI
share|improve this question
add comment

1 Answer 1

Phew! After going through quite a number of Ubuntu forums and even changing over to XUbuntu 12.04 (precise pangolin) installation, I was finally able to arrive at a solution to get sound working on my laptop.

I strongly recommend anyone having similar issue to go through Sound Troubleshooting - Ubuntu Forums.

There are different default combination of drivers offered by Ubuntu. Pulse Audio, ALSA and then Open Sound Linux drivers (oss-linux). The suggested steps is focussed on ALSA.

In my case, I had to follow the following steps:

Step 1:

I completely cleared the contents of file /etc/modprobe.d/alsa-base.conf and just added the following:

options snd-hda-intel index=0 model=auto

Step 2:

Downloaded the relevant ALSA audio development package relevant to Ubuntu 12.04 from the following site. It was alsa-hda-dkms_0.201301181937~precise1_all.deb.

sudo dpkg -i alsa-hda-dkms_0.201301181937~precise1_all.deb

If the above step complains that dkms package is missing, do the following:

sudo apt-get install dkms

Step 3:

Reboot the system. When you log back in, you can try the following to see the list of sound devices on your system (the following was present in my laptop):

sudo aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Step 4:

On terminal, open alsamixer and unmute the master volume and adjust sound levels and try playing a sample audio file.

Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.