Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had a Unity environment on my laptop and yesterday I decide to change it to kde, so I typed:

sudo apt-get install kde

and installation was correct, I choose lightdm in menuconfig as default login shell/service. After reboot, I have preety Ubuntu kde login screen, but when I type login and password lightdm dont pass me to desktop, and X-Server reset itself, and again I see a a KDE login window. (I have option to choose Unity, gnome, kde unity-2D all of them restarts X11)

Is possible to fix that and use kde and lightdm? Or I must remove one of them? My goal is to dont use Unity, but I dont want reinstall by ubuntu to xbuntu or something similar.

share|improve this question
ps. I tried to apt-get install lightdm --reinstall but it don't help me – Mazeryt Jan 17 '13 at 23:18
I would recommend installing kubuntu-desktop via sudo apt-get install kubuntu-desktop to make sure all the dependancies are configured and setup. – jjesse Apr 18 '13 at 2:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.