Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I keep CD/USB automounting (works fine) BUT without auto-opening in Nautilus?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

System->Preferences->Removable Drives (only in Ubuntu version 9.04 and below)

There should be setting there to chose what happens when removable media is inserted.

share|improve this answer
    
I don't see that option in my menu... should I dpkg-reconfigure something? OR do you know how to get to that screen manually (alt-f2)? –  Diego Mijelshon Aug 17 '10 at 2:35
    
@diego I am not on my ubuntu box. the option is there. let me get you a link I have modified my answer with a link. –  myusuf3 Aug 17 '10 at 3:40
    
Excellent link, that'll probably do! –  Diego Mijelshon Aug 17 '10 at 4:00
1  
"Removable Drives and Media" was removed from System > Preferences starting with 9.10. –  Roger Pate Aug 17 '10 at 6:00

From inside Nautilus: Edit > Preferences > Media

Here you can change behavior for recognized media types (CD, Music Player, Photos, etc.) and unrecognized ("Browse media when inserted" option).

Screenshot

share|improve this answer
3  
That the UI way to change /apps/nautilus/preferences/media_automount_open, right? –  Diego Mijelshon Aug 17 '10 at 12:56
    
Nevermind, it is :-) Thanks! –  Diego Mijelshon Aug 17 '10 at 13:14
    
@Diego you should mark this as the accepted answer. –  RolandiXor Jun 5 '11 at 21:59
    
@RolandTaylor: I actually fixed the problem with dustyprogrammer's link. Both solutions do the same in the end. –  Diego Mijelshon Jun 6 '11 at 0:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.