Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Samsung Galaxy S II but my Ubuntu 10.04 laptop, although it recognizes the phone when I connect it with a USB. won't allow me to get into the phone. Do I need special drivers?

share|improve this question
add comment

marked as duplicate by LiveWireBT, Florian Diesch, karel, BuZZ-dEE, Avinash Raj Jan 28 at 4:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5 Answers

No you don't need drivers. You need to enable using phone as mass storage.

  1. Connect phone by USB to your PC.
  2. On your Galaxy S2 phone, a message will appear with the ability to select Mass storage as a connection option. Make sure you use this one, opposed to Media Transfer Protocol for example.

You now can now use your phone like you can use any USB flash drive. Mount and explore your files in the file manager.

share|improve this answer
    
Hi ZDroid, I have followed your instructions but no mass storage option appears on the S2!!! –  Winston Jan 17 '13 at 20:56
1  
@Winston Disable USB Debugging first. See this video on Youtube on how to do that. –  gertvdijk Jan 17 '13 at 21:52
    
@gertvdijk Rather than have to watch a youtube video (which might get removed in the future), it'd be better to summarise this information in the answer itself. Or create a new answer. –  Sparhawk Jan 18 '13 at 0:11
    
@Sparhawk I think I've summarized it fairly well: "Disable USB Debugging". In my opinion this should stay a comment, as 1) not a lot of people have USB debugging on, and 2) steps would be very specific in the Samsung Android ROM, so kinda offtopic on Ask Ubuntu. –  gertvdijk Jan 18 '13 at 0:14
    
@gertvdijk Okay. I didn't watch the video, so I don't know how complicated it is, but I presumed that because there was a video it'd be slightly complicated at least. But then again youtube is filled with detritus, so… :) Good points, anyway. –  Sparhawk Jan 18 '13 at 0:27
add comment

I have a Note 2 and how I get it working is by unlocking the screen and leave it at the home screen. And It detects it as a mass storage device I assume it's very similar (If not the same) with a S2, Note, S3, Note 2, S4, Note 3

share|improve this answer
add comment

Just in case you have done what I have done. I was using a cable not supplied by Samsung. Although this seems to charge my phone it would never allow you to use your phone as a Mass Storage device.

Changed my cable - problem solved....

share|improve this answer
add comment

You do not need any drivers at all; it's all automatic. How you access the phone, however, completely depends on the version of Android and whether or not you are using a custom rom.

Stock (factory) Samsung

If you have never run system updates on the phone before, do the following:
1) Plug the phone into the PC
2) Drag down the notification bar
3) Click on 'USB connected'
4) Click on 'Connect USB storage'

Samsung Android 4.0.4

If you are running Android 4, the phone will by default switch to MTP or PTP mode. From personal experience I've learned that MTP does not work very well at times, as it can make the device appear empty or report connection problems. To use USB storage mode, do the following:
1) Make the sure the phone is NOT plugged into the computer
2) Go to Settings->More Settings->USB Utilities->Mass storage mode
3) Connect the USB cable
4) Click on 'Connect USB storage'

Custom roms

Custom Android roms generally have their own way of doing things. It is important to note that some custom roms don't have mass storage mode at all; I have had cases where resurrection remix roms only had MTP and PTP mode, but no mass storage mode (which is a major reason that I stopped using it and switched to WanamLite instead).
Generally, you'll want to look for the mass storage option in the following places:
* Inside the notification bar->USB Connected / USB Mass Storage
* Inside the notification bar->Disk Mode
* Setting->Wireless and networks
* Settings->More
* Settings->Storage
If you still can't find it, ensure that your rom supports mass storage mode.

Hope this helps

share|improve this answer
add comment

On your android phone, go to Application->Settings

In there, go to Wirelessand Network and select USB Utilities

Click on Connect Storage to PC

A message should pop up: Connect USB cable to use mass storage

Now connect the USB cable to computer

A green android robot should be on display with an option of “Connect USB storage“, click on it

The green robot turns orange now and now you can access the files on the SD card of your phone

Source: http://www.computerandyou.net/2012/01/how-to-fix-android-samsung-galaxy-s2-not-recognized-on-linux/

share|improve this answer
add comment

protected by Community Jan 27 at 13:17

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.