Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am working with multiple documents in LibreOffice, all are open in separate windows. when I click the exit button, or go to the file menu clicking on "quit", ALL windows close, not just the one I wanted to close.

How do I avoid closing ALL windows, and how can I just close one of the windows?

share|improve this question
add comment

1 Answer

LibreOffice is an MDI (multiple document interface) program. There is always only a single parent container for all open documents. This is true no matter what kind of document is open: Writer, Calc, and so on.

When you have multiple documents open and each is in its own non-maximized window, it may appear that each window is a separate instance of LibreOffice; but it is not. All windows still belong to a single parent container.

When you choose File > Exit, you are closing the parent container and all open documents will close.

How to close the active document and leave the others open

You have several options.

  1. Use File > Close. The Close command is above Save in the standard menu.

  2. Use Alt+F4

  3. Click the Close (X) button on the title bar of the document window. If the document is maximized, the Close (X) button on the global menubar will belong to the active document.

share|improve this answer
    
Thank you for your explanation. This solves my problem. File>Close worked, clicking the Close (x) button on the menu sometimes works, and sometimes it closes all windows. –  sabinedoll Jan 18 '13 at 0:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.