Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My ubuntu(12.04) never shutdown. Did not help this: 1) sudo halt 2) sudo shutdown -h now 3) update grub(acpi-force)

I think it's after installaton AMD Catalyst. My friend has similar problem and he thiks it's after Gnome-shell installation.

Who have similar problem, help please!

UPDATE This is my syslog

$ sudo /sbin/acpi_available && echo $?
share|improve this question
Welcome to Ask Ubuntu! How long did you wait until you gave up? What does the screen say at that point? Can you provide the logs once you've rebooted the PC after a failed shutdown attempt? Find the lines around the time the shutdown was expected in /var/log/syslog. Also provide the output of the following command: sudo /sbin/acpi_available && echo $?. Please provide this information by editing your question. – gertvdijk Jan 17 '13 at 16:13
I had the same problem, I also think was caused by AMD drivers (fglrx). I can say that after upgrade to 12.10 it's almost solved (it happens but in very few cases) – Pisu Jan 18 '13 at 7:18
Can we solve this problem? – xdsemx Jan 18 '13 at 14:00
In the syslog output you got it clearly shows a nice and clean shutdown: Jan 17 20:20:01 work kernel: Kernel logging (proc) stopped. So, now what exactly happens? What do you see on the screen at the time you expect it to shut down? Does rebooting work? sudo shutdown -r now What version of the fglrx driver do you have installed? (and how?) Have you tried uninstalling it to see whether is actually is the cause? What happens from a Live CD? etc. etc. – gertvdijk Jan 18 '13 at 17:27
gertvdijk, I see quit dots and logo ubutntu. Rebooting doesnt work. I was installed fglrx in ubuntu PPA fglrxinfo: display: :0 screen: 0 OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: AMD Radeon HD 7700 Series OpenGL version string: 4.2.11627 Compatibility Profile Context [ 19.697] (II) fglrx(0): Kernel Module Version Information: [ 19.697] (II) fglrx(0): Name: fglrx [ 19.697] (II) fglrx(0): Version: 8.96.4 From liveCD ubuntu normaly shutdown. – xdsemx Jan 21 '13 at 7:16

Have you Tried Using ' sudo shutdown -P now ', which halts the system then requests a power off or perhaps switching to a tty console and seeing what happens from there ? If your really in a jam you could also try ctrl+alt+del at a tty console not gnome or gnome-terminal emulator and the system should reboot. If you continue to have issues, I'd try reinstalling before making a bug-report as it could just be a goof in your installation.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.