Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With Ubuntu 10.10 Lucid and its default Firefox 3.6.13, when I follow the normal installation procedure of Google Gears I receive this error:

"Google Gears" could not be installed because it is not compatible with your Firefox build type (Linux_x86-gcc3)

enter image description here

How can I install Gears on the latest Ubuntu with default Firefox?

share|improve this question
    
"On February 19, 2010, the Gears team at Google announced that the development of Google Gears had stopped, as they are working on bringing all of the Gears capabilities into web standards like HTML5". what site that you are using requires gears? –  Alaukik Feb 2 '11 at 10:04
    
@Alaukik: Gmail offline –  Nicolas Raoul Feb 2 '11 at 11:27

3 Answers 3

up vote 2 down vote accepted

WRONG: Head to the Google Gears site over here, then just follow the instructions. Please note that right now, Google Gears is being deprecated to make way for a newer, more powerful tool.

EDIT: After having the question clarified and expanded some more, I have a solution. Install Google Gears from here (It's a direct download), and enjoy. Worked for me on Ubuntu 10.10 and Firefox 3.6.13. enter image description here

share|improve this answer
    
As you can see on the screenshot, it does not work. Which versions of Ubuntu/Firefox are you using? –  Nicolas Raoul Feb 2 '11 at 11:32
    
I had installed it previously. I've got an edit coming in a moment. –  jrg Feb 2 '11 at 12:09
    
Thanks, the EDIT section works, Gmail offline runs fine :-) Minor annoyance: Every couple of hours, the same popup appears, saying: "Google Gears" could not be installed because it is not compatible with your Firefox build type (Linux_x86-gcc3). Please contact the author of this item about the problem. –  Nicolas Raoul Feb 9 '11 at 3:21
    
Odd. I'll contact them with that. And the answer below me is worth a look at as well. –  jrg Feb 9 '11 at 10:08

On Lucid, there is a gears package in the archive. We removed it from Maverick since gears is dead upstream.

share|improve this answer

The solution from Jrgifford maybe nice for this XPI. But I want to share with you and other people the following solution for all the XPI's with compatible problem:

Editing an add-on to change its compatibility

See link: http://kb.mozillazine.org/Editing_an_add-on_to_change_its_compatibility

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.