Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello
I need to set a hotkey in ubuntu 12.10, I use:

gsettings(dconf)  
 gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/ binding '<Primary><Alt>s'<br>  
 gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/ binding '<Primary><Alt>s'<br> 
 gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/ command 'gnome-terminal' 

But when I look at this schema with gsettings I just see:

gsettings get org.gnome.settings-daemon.plugins.media-keys custom-keybindings
@as []

But when I use dconf to see this schema:

dconf list /org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/
 binding
 command

What am I doing wrong?

share|improve this question
    
May I ask why you are using dconf and gsettings? There are many easier ways to create keyboard shortcuts/hotkeys. –  Seth Jan 17 '13 at 17:20
    
Because i need to set hot key in post install script. What are this ways? –  minaevmike Jan 18 '13 at 8:43
    
Ah, well they won't work for a post install script I'm afraid. –  Seth Jan 18 '13 at 16:14
    
Why not? in ubuntu 12.04 i use gconftool-2 but in 12.10 it doesn't work –  minaevmike Jan 18 '13 at 17:42

2 Answers 2

First try creating custom2:

gsettings set org.gnome.settings-daemon.plugins.media-keys custom-keybindings "['others', '/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/']"

(Where others is a shorthand for the other key bindings already defined. Just to be sure you don't delete them.)

Now that is out of way, configure your custom2:

gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/ binding '<Primary><Alt>s'
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/ command 'gnome-terminal'
gsettings set org.gnome.settings-daemon.plugins.media-keys.custom-keybinding:/org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/ name 'Open a terminal window'
share|improve this answer

Use these commands:

dconf read /org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/name
dconf read /org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/binding
dconf read /org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom2/command
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.