Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to upgrade our ubuntu server 11.04 to 11.10. I did an apt-get update and apt-get dist-upgrade. Now, im trying to execute do-release upgrade. This is the error i get:

Err http://archive.ubuntu.com/ubuntu/ oneiric/main librpmsign0
403  Forbidden: IPS signature match [IP: 91.189.92.202 80] 

This is the full output:

root@zienix:/var/cache/apt# do-release-upgrade
Checking for a new ubuntu release
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

Get:1 Upgrade tool signature [198 B]                                                                                                                                                                            
Get:2 Upgrade tool [1471 kB]                                                                                                                                                                                    
Fetched 1471 kB in 0s (0 B/s)                                                                                                                                                                                   
authenticate 'oneiric.tar.gz' against 'oneiric.tar.gz.gpg' 
extracting 'oneiric.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Ign http://security.ubuntu.com natty-security InRelease                                                                                                                                                         
Ign http://archive.ubuntu.com natty InRelease                                                                                                                                                                   
Ign http://archive.ubuntu.com natty-updates InRelease                                                                                                                                                           
Hit http://security.ubuntu.com natty-security Release.gpg                                                                                                                                                       
Hit http://archive.ubuntu.com natty Release.gpg                                                                                                                                                                 
...                                                                                                                                                                                                                                                       
Get:55 http://archive.ubuntu.com oneiric-updates/main TranslationIndex [74 B]                                                                                                                                   
Get:56 http://archive.ubuntu.com oneiric-updates/multiverse TranslationIndex [72 B]                                                                                                                             
Get:57 http://archive.ubuntu.com oneiric-updates/restricted TranslationIndex [72 B]                                                                                                                             
Get:58 http://archive.ubuntu.com oneiric-updates/universe TranslationIndex [73 B]                                                                                                                               
Get:59 http://archive.ubuntu.com oneiric/main Translation-en [701 kB]                                                                                                                                           
Get:60 http://archive.ubuntu.com oneiric/multiverse Translation-en [92.6 kB]                                                                                                                                    
Get:61 http://archive.ubuntu.com oneiric/restricted Translation-en [2229 B]                                                                                                                                     
Get:62 http://archive.ubuntu.com oneiric/universe Translation-en [3165 kB]                                                                                                                                      
Get:63 http://archive.ubuntu.com oneiric-updates/main Translation-en [205 kB]                                                                                                                                   
Get:64 http://archive.ubuntu.com oneiric-updates/multiverse Translation-en [3524 B]                                                                                                                             
Get:65 http://archive.ubuntu.com oneiric-updates/restricted Translation-en [1547 B]                                                                                                                             
Get:66 http://archive.ubuntu.com oneiric-updates/universe Translation-en [87.6 kB]                                                                                                                              
Fetched 24.0 MB in 6s (657 kB/s)                                                                                                                                                                                

Checking package manager
Reading package lists... Done    
Building dependency tree          
Reading state information... Done
Building data structures... Done 

Calculating the changes

Calculating the changes
No candidate ver:  libdns66
No candidate ver:  libdrm-nouveau1
No candidate ver:  libeggdbus-1-0
No candidate ver:  libgirepository1.0-1
No candidate ver:  libicu42
No candidate ver:  libisc60
No candidate ver:  libisccfg60
No candidate ver:  libpango1.0-common
No candidate ver:  libxapian15
No candidate ver:  linux-image-2.6.35-22-virtual
No candidate ver:  linux-image-2.6.35-28-virtual
No candidate ver:  linux-image-2.6.35-32-virtual

Do you want to start the upgrade? 


1 installed package is no longer supported by Canonical. You can 
still get support from the community. 

5 packages are going to be removed. 84 new packages are going to be 
installed. 389 packages are going to be upgraded. 

You have to download a total of 8784 . This download will take about 
1 second with your connection. 

Fetching and installing the upgrade can take several hours. Once the 
download has finished, the process cannot be cancelled. 

Continue [yN]  Details [d]y

Fetching
Err http://archive.ubuntu.com/ubuntu/ oneiric/main librpmsign0 amd64 4.9.0-7                                                                                                                                    
  403  Forbidden: IPS signature match [IP: 91.189.92.202 80]                                                                                                                                                    
Fetched 0 B in 0s (0 B/s)                                                                                                                                                                                       
Err http://archive.ubuntu.com/ubuntu/ oneiric/main librpmsign0 amd64 4.9.0-7                                                                                                                                    
  403  Forbidden: IPS signature match [IP: 91.189.92.201 80]                                                                                                                                                    
Fetched 0 B in 0s (0 B/s)                                                                                                                                                                                       
Err http://archive.ubuntu.com/ubuntu/ oneiric/main librpmsign0 amd64 4.9.0-7                                                                                                                                    
  403  Forbidden: IPS signature match [IP: 91.189.92.202 80]                                                                                                                                                    
Fetched 0 B in 0s (0 B/s)                                                                                                                                                                                       

Could not download the upgrades 

The upgrade has aborted. Please check your Internet connection or 
installation media and try again. All files downloaded so far have 
been kept. 

Failed to fetch 
http://archive.ubuntu.com/ubuntu/pool/main/r/rpm/librpmsign0_4.9.0-7_amd64.deb 
403 Forbidden: IPS signature match [IP: 91.189.92.202 80] 



Restoring original system state

Aborting
Reading package lists... Done    
Building dependency tree          
Reading state information... Done
Building data structures... Done 
share|improve this question
add comment

1 Answer 1

The problem is probably on your end, as I was able to download the same file from home.

There is probably a fancy "Intrusion prevention system" that was too strictly configured on your end that is blocking you from downloading the file.

You could try downloading it from another mirror if the problem is for this specific mirror, see the complete list :

http://packages.ubuntu.com/oneiric/amd64/librpmsign0/download

Just find one, copy the download link, wget it and install it with dpkg (dpkg -i librpmsign0_4.9.0-7_amd64.deb) before starting the upgrade again.

If that fails, try changing the repository used in /etc/apt/sources.list.

If that fails too, you will need to add exceptions to the IPS.

share|improve this answer
    
Changed our firewall rules and now the download works! Still it's strange.. we never had any problem download packages from ubuntu –  nbrys Jan 18 '13 at 8:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.