Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is, when I want to install apps like apt-get install <appsname>, I get an error:

root@bt:/# apt-get install bluefish
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  adduser apt apt-utils aspell aspell-en base-files base-passwd
  busybox-initramfs ca-certificates consolekit coreutils cpio cpp cpp-4.4 dbus
  dbus-x11 debconf debconf-i18n debianutils defoma dictionaries-common dmsetup
  dosfstools dpkg e2fslibs e2fsprogs esound-clients esound-common file
  findutils fontconfig fontconfig-config fuse-utils gamin gawk gcc-4.4-base
  gconf2 gconf2-common ghostscript gnome-keyring gnome-mime-data gnupg
  gnupg-curl gpgv gsfonts gvfs gvfs-backends hdparm hicolor-icon-theme
  ifupdown indicator-application initramfs-tools initramfs-tools-bin
  initscripts insserv klibc-utils libacl1 libappindicator0 libarchive1
  libart-2.0-2 libasound2 libaspell15 libatasmart4 libatk1.0-0 libatk1.0-data
  libattr1 libaudiofile0 libavahi-client3 libavahi-common-data
  libavahi-common3 libavahi-glib1 libblkid1 libbluetooth3 libbonobo2-0
  libbonobo2-common libbonoboui2-0 libbonoboui2-common libbz2-1.0 libc-bin
  libc6 libc6-i686 libcairo2 libcap2 libcdio-cdda0 libcdio-paranoia0 libcdio10
  libck-connector0 libcomerr2 libcups2 libcupsimage2 libcurl3-gnutls
  libdatrie1 libdb4.8 libdbus-1-3 libdbus-glib-1-2 libdbusmenu-glib1
  libdbusmenu-gtk1 libdevmapper1.02.1 libdirectfb-1.2-0 libdrm-intel1
  libdrm-nouveau1 libdrm-radeon1 libdrm2 libeggdbus-1-0 libesd0 libexif12
  libexpat1 libffi5 libfontconfig1 libfontenc1 libfreetype6 libfribidi0
  libfuse2 libgail18 libgamin0 libgcc1 libgconf2-4 libgcr0 libgcrypt11
  libgdbm3 libgdu0 libglade2-0 libglib2.0-0 libglib2.0-data libgmp3c2
  libgnome-keyring0 libgnome2-0 libgnome2-common libgnomecanvas2-0
  libgnomecanvas2-common libgnomeui-0 libgnomeui-common libgnomevfs2-0
  libgnomevfs2-common libgnutls26 libgomp1 libgp11-0 libgpg-error0
  libgphoto2-2 libgphoto2-port0 libgpm2 libgs8 libgssapi-krb5-2 libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgudev-1.0-0 libgvfscommon0 libhal-storage1
  libhal1 libice6 libidl0 libidn11 libimobiledevice0 libindicator0 libjasper1
  libjpeg62 libjson-glib-1.0-0 libk5crypto3 libkeyutils1 libklibc libkrb5-3
  libkrb5support0 liblcms1 libldap-2.4-2 liblocale-gettext-perl libltdl7
  liblzma1 libmagic1 libmagickcore2 libmagickwand2 libmpfr1ldbl libncurses5
  libncursesw5 libnewt0.52 libnih-dbus1 libnih1 libntfs-3g75 libntfs10
  libopenobex1 liborbit2 libpam-ck-connector libpam-gnome-keyring
  libpam-modules libpam-runtime libpam0g libpango1.0-0 libpango1.0-common
  libpaper-utils libpaper1 libparted0debian1 libpcre3 libpixman-1-0 libplist1
  libplymouth2 libpng12-0 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpopt0 libproxy0 libpython2.6 libreadline6
  libsasl2-2 libsasl2-modules libselinux1 libsepol1 libsgutils2-2 libslang2
  libsm6 libsmbclient libsoup-gnome2.4-1 libsoup2.4-1 libsqlite3-0 libss2
  libssl0.9.8 libstdc++6 libsysfs2 libtalloc2 libtasn1-3
  libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libthai-data
  libthai0 libtiff4 libts-0.0-0 libudev0 libusb-0.1-4 libusb-1.0-0 libusbmuxd1
  libuuid1 libwbclient0 libx11-6 libx11-data libxau6 libxcb-render-util0
  libxcb-render0 libxcb1 libxcomposite1 libxcursor1 libxdamage1 libxdmcp6
  libxext6 libxfixes3 libxfont1 libxft2 libxi6 libxinerama1 libxml2 libxrandr2
  libxrender1 libxt6 lsb-base lzma make makedev mime-support module-init-tools
  mount mountall mtools ncurses-bin net-tools netbase ntfs-3g ntfsprogs
  obex-data-server openssl passwd perl perl-base perl-modules plymouth
  plymouth-theme-ubuntu-text policykit-1 policykit-1-gnome powermgmt-base
  procps psfontmgr psmisc python python-dbus python-gobject python-minimal
  python-support python2.6 python2.6-minimal readline-common sed
  sensible-utils sgml-base shared-mime-info sysv-rc sysvinit-utils tsconf
  ttf-dejavu-core tzdata ubuntu-keyring ucf udev udisks upstart usbmuxd
  util-linux uuid-runtime whiptail x-ttcidfont-conf x11-common
  xfonts-encodings xfonts-utils xml-core zlib1g
Suggested packages:
  ecryptfs-utils aptitude synaptic wajig dpkg-dev apt-doc bzip2 python-apt
  aspell-doc spellutils galeon firefox abrowser www-browser weblint-perl
  weblint libxml2-utils php5-cli tidy cpp-doc gcc-4.4-locales debconf-doc
  debconf-utils libterm-readline-gnu-perl libgnome2-perl libnet-ldap-perl
  defoma-doc dfontmgr libfont-freetype-perl ispell emacsen-common jed-extra
  gpart parted e2fsck-static mlocate locate slocate gconf-defaults-service
  ghostscript-cups ghostscript-x hpijs gnupg-doc xloadimage imagemagick eog
  libpcsclite1 apmd iproute dhcp3-client dhcp-client ppp bootchart
  libasound2-plugins libbonobo2-bin glibc-doc cups-common esound rng-tools
  desktop-base gnome-icon-theme libgnomevfs2-bin libgnomevfs2-extra gnutls-bin
  gphoto2 gtkam gpm krb5-doc krb5-user librsvg2-common libjasper-runtime
  liblcms-utils libmagickcore2-extra libpam-doc ttf-japanese-gothic
  ttf-japanese-mincho ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp
  ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp libparted0-dev
  libparted0-i18n libsasl2-modules-otp libsasl2-modules-ldap
  libsasl2-modules-sql libsasl2-modules-gssapi-mit
  libsasl2-modules-gssapi-heimdal sg3-utils make-doc nfs-common floppyd
  openssl-doc perl-doc python-doc python-tk python-profiler python-dbus-doc
  python-dbus-dbg python-gobject-dbg python2.6-doc python2.6-profiler binutils
  binfmt-support sgml-base-doc sysv-rc-conf bum sash watershed xfsprogs
  reiserfsprogs mdadm cryptsetup util-linux-locales kbd console-tools
  debhelper
The following NEW packages will be installed:
  adduser apt apt-utils aspell aspell-en base-files base-passwd bluefish
  busybox-initramfs ca-certificates consolekit coreutils cpio cpp cpp-4.4 dbus
  dbus-x11 debconf debconf-i18n debianutils defoma dictionaries-common dmsetup
  dosfstools dpkg e2fslibs e2fsprogs esound-clients esound-common file
  findutils fontconfig fontconfig-config fuse-utils gamin gawk gcc-4.4-base
  gconf2 gconf2-common ghostscript gnome-keyring gnome-mime-data gnupg
  gnupg-curl gpgv gsfonts gvfs gvfs-backends hdparm hicolor-icon-theme
  ifupdown indicator-application initramfs-tools initramfs-tools-bin
  initscripts insserv klibc-utils libacl1 libappindicator0 libarchive1
  libart-2.0-2 libasound2 libaspell15 libatasmart4 libatk1.0-0 libatk1.0-data
  libattr1 libaudiofile0 libavahi-client3 libavahi-common-data
  libavahi-common3 libavahi-glib1 libblkid1 libbluetooth3 libbonobo2-0
  libbonobo2-common libbonoboui2-0 libbonoboui2-common libbz2-1.0 libc-bin
  libc6 libc6-i686 libcairo2 libcap2 libcdio-cdda0 libcdio-paranoia0 libcdio10
  libck-connector0 libcomerr2 libcups2 libcupsimage2 libcurl3-gnutls
  libdatrie1 libdb4.8 libdbus-1-3 libdbus-glib-1-2 libdbusmenu-glib1
  libdbusmenu-gtk1 libdevmapper1.02.1 libdirectfb-1.2-0 libdrm-intel1
  libdrm-nouveau1 libdrm-radeon1 libdrm2 libeggdbus-1-0 libesd0 libexif12
  libexpat1 libffi5 libfontconfig1 libfontenc1 libfreetype6 libfribidi0
  libfuse2 libgail18 libgamin0 libgcc1 libgconf2-4 libgcr0 libgcrypt11
  libgdbm3 libgdu0 libglade2-0 libglib2.0-0 libglib2.0-data libgmp3c2
  libgnome-keyring0 libgnome2-0 libgnome2-common libgnomecanvas2-0
  libgnomecanvas2-common libgnomeui-0 libgnomeui-common libgnomevfs2-0
  libgnomevfs2-common libgnutls26 libgomp1 libgp11-0 libgpg-error0
  libgphoto2-2 libgphoto2-port0 libgpm2 libgs8 libgssapi-krb5-2 libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgudev-1.0-0 libgvfscommon0 libhal-storage1
  libhal1 libice6 libidl0 libidn11 libimobiledevice0 libindicator0 libjasper1
  libjpeg62 libjson-glib-1.0-0 libk5crypto3 libkeyutils1 libklibc libkrb5-3
  libkrb5support0 liblcms1 libldap-2.4-2 liblocale-gettext-perl libltdl7
  liblzma1 libmagic1 libmagickcore2 libmagickwand2 libmpfr1ldbl libncurses5
  libncursesw5 libnewt0.52 libnih-dbus1 libnih1 libntfs-3g75 libntfs10
  libopenobex1 liborbit2 libpam-ck-connector libpam-gnome-keyring
  libpam-modules libpam-runtime libpam0g libpango1.0-0 libpango1.0-common
  libpaper-utils libpaper1 libparted0debian1 libpcre3 libpixman-1-0 libplist1
  libplymouth2 libpng12-0 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpopt0 libproxy0 libpython2.6 libreadline6
  libsasl2-2 libsasl2-modules libselinux1 libsepol1 libsgutils2-2 libslang2
  libsm6 libsmbclient libsoup-gnome2.4-1 libsoup2.4-1 libsqlite3-0 libss2
  libssl0.9.8 libstdc++6 libsysfs2 libtalloc2 libtasn1-3
  libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libthai-data
  libthai0 libtiff4 libts-0.0-0 libudev0 libusb-0.1-4 libusb-1.0-0 libusbmuxd1
  libuuid1 libwbclient0 libx11-6 libx11-data libxau6 libxcb-render-util0
  libxcb-render0 libxcb1 libxcomposite1 libxcursor1 libxdamage1 libxdmcp6
  libxext6 libxfixes3 libxfont1 libxft2 libxi6 libxinerama1 libxml2 libxrandr2
  libxrender1 libxt6 lsb-base lzma make makedev mime-support module-init-tools
  mount mountall mtools ncurses-bin net-tools netbase ntfs-3g ntfsprogs
  obex-data-server openssl passwd perl perl-base perl-modules plymouth
  plymouth-theme-ubuntu-text policykit-1 policykit-1-gnome powermgmt-base
  procps psfontmgr psmisc python python-dbus python-gobject python-minimal
  python-support python2.6 python2.6-minimal readline-common sed
  sensible-utils sgml-base shared-mime-info sysv-rc sysvinit-utils tsconf
  ttf-dejavu-core tzdata ubuntu-keyring ucf udev udisks upstart usbmuxd
  util-linux uuid-runtime whiptail x-ttcidfont-conf x11-common
  xfonts-encodings xfonts-utils xml-core zlib1g
0 upgraded, 314 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/92.5MB of archives.
After this operation, 361MB of additional disk space will be used.
Do you want to continue [Y/n]? y
E: Could not perform immediate configuration on 'libattr1'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
share|improve this question
1  
did you try to install explicitly the libattr1 package ? –  eephyne Jan 17 '13 at 9:15
    
@Eliahkagan no not yet!!i really depressed plz help me!! –  Rajendra Sharma Jan 17 '13 at 9:25

1 Answer 1

I believe the E: Could not perform immediate configuration on ... error sometimes occurs when a package needs an updated libc for to install...but the updated libc is not installed yet.

Try this:

sudo apt-get update && sudo apt-get install libc6

If that works without problems, try this, but don't allow it to proceed if it want to remove anything, especially libc6 (in that case please comment here and add details to your question):

sudo apt-get install libc6-i686

If that all works, see if you can complete the rest of the update:

sudo apt-get upgrade

If it doesn't work, please comment and post the details, including all the output of everything.

Acknowledgements:
  This answer is loosely based on Edward van Kuik's answer to apt error: Could not perform immediate configuration on (SU).
  (You don't have any packages not being installed, so dist-upgrade is unnecessary here.)

share|improve this answer
    
I had try the first command and the problem is same i.e.root@bt:~# sudo apt-get update && sudo apt-get install libc6 The following extra packages will be installed: apt apt-utils ca-certificates coreutils debconf debconf-i18n dpkg findutils gnupg-curl libsasl2-modules Install these packages without verification [y/N]? y E: Could not perform immediate configuration on 'libselinux1'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2) –  Rajendra Sharma Jan 17 '13 at 9:49
    
IN comment it doesnt take more character so i deletd the middle –  Rajendra Sharma Jan 17 '13 at 9:55
    
@RajendraSharma Please put all the details including all the text from the terminal, even though it's long in your question by editing your question. Or if it's too long you can put it at paste.ubuntu.com. Either way, please edit your question to update it, so other people can help too who don't already know what's going on. Comments are just for short stuff, and to let me know you've updated the question and want me to look at it, that kind of stuff. –  Eliah Kagan Jan 17 '13 at 10:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.