Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to run dcop, since my yakuake cannot be shown again in my Cinnamon, and I don't want to restart my yakuake. I found that this command can make my yakuake show again:

dcop yakuake DCOPInterface slotToggleState

But I got no luck running it:

$ dcop
No command 'dcop' found, did you mean:
 Command 'dtop' from package 'diod' (universe)
 Command 'dccp' from package 'dcap' (universe)
 Command 'bcop' from package 'compiz-fusion-bcop' (universe)
dcop: command not found

I've tried to search it, but no luck:

$ apt-cache search dcop
courier-filter-perl - purely Perl-based mail filter framework for the Courier MTA
gambas3 - Complete visual development environment for Gambas
grace - XY graphing and plotting tool
jless - A file pager program, similar to more(1) supporting ISO2022
konversation - user friendly Internet Relay Chat (IRC) client for KDE
xgraph - Plotting program, reads stdin, allows interactive zooming

So, in which package dcop application is contained?

share|improve this question
    
What's dcop exactly? It seems not to be packaged in Ubuntu. Can you point to a web page or source? –  gertvdijk Jan 17 '13 at 1:27
    
Desktop COmmunication Protocol en.wikipedia.org/wiki/DCOP –  Kokizzu Jan 17 '13 at 5:27
add comment

2 Answers

up vote 3 down vote accepted

It's obsolete and has been removed

DCOP the protocol is now being handled by D-Bus, the former dcop command is an old KDE thing.

It's even in the Wikipedia: DCOP page you provided yourself!

DCOP was replaced by D-Bus in KDE Software Compilation 4.

[...]

D-Bus, a message bus system standardized by freedesktop.org, was heavily influenced by the DCOP system and replaces DCOP in KDE Software Compilation 4.

So, have a look at the possibilities the dbus-* commands can do for you.

I think you were looking at a very old or mixed up sources, as Cinnamon is quite new thing while this has been obsoleted since the release of KDE 4 in 2008.

Move to D-Bus

In KDE, to toggle the window state of Yakuake Terminal emulator, do this (verified working):

qdbus org.kde.yakuake /yakuake/window toggleWindowState

How to get this working in Cinnamon? Not sure, as Yakuake is a KDE program and I'm not familiar with non-Qt D-Bus implementations.

share|improve this answer
    
ok many thanks.. i've found the dbus (qdbus command) but it's not working.. so i give up for now.. XD –  Kokizzu Jan 17 '13 at 10:18
    
@KiswonoPrayogo Try the command I used. While still not clear what you wanted to accomplish to start with, this example is working for me. The slotToggleState state seems not available as an option to /yakuake/window. –  gertvdijk Jan 17 '13 at 10:27
    
no, it's not working.. | the problem: sometimes KDE global shortcut stopped working, so i can't call yakuake back, even by calling yakuake from gnome-console again.. it wont show up.. –  Kokizzu Jan 17 '13 at 11:29
    
@KiswonoPrayogo What do you mean "it's not working"? Do you get an error message? Does Yakuake do something else? What exact command did you try? etc. –  gertvdijk Jan 17 '13 at 11:37
1  
@KiswonoPrayogo then I'm lost as to what is different in your set up. You could try debugging and finding another way using qdbusviewer, e.g. the raiseSession method. –  gertvdijk Jan 17 '13 at 12:34
show 2 more comments

According to Ubuntu Package Search : http://packages.ubuntu.com/search?suite=lucid&arch=any&searchon=contents&keywords=dcop

It is contain in kdelibs until lucid (Ubuntu 10.04).

share|improve this answer
    
This is the completion hinting on dcop as far as I can see. –  gertvdijk Jan 17 '13 at 1:26
    
@gertvdijk good point, re-do search. –  John Siu Jan 17 '13 at 1:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.