Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Both my monitors (one over DVI other over HDMI) have a native resolution of 1920x1080 (16:9) but the only two options for resolution in the "Display" section of system settings are 800x600 (4:3) and 1024x768 (4:3).

The "additional drivers" tab in the "Software Sources" section of system settings tells me I have no drivers running, despite installing NVidia drivers multiple times.

I downloaded and installed Jockey from the Software Centre, which told me that I am running the NVidia driver. Since closing Jockey I am unable to find any trace of it in my system. I can't open it in Terminal either. When I search "nvidia" in the dash, I get "NVidia X Server Settings" and in there as well I have the same resolution options as in "Display" settings.

Additional information: With only one monitor, the issue persists. Mt driver version is nvidia-current, 304.64. Logging in with "Guest Login", I have all resolution options available, including 1920x1080. There is no xorg.conf file in /etc/X11 there is, however: xorg.conf.failsafe. I tried deleting .nvidia-settings-rc from Home and this had no effect.

I am running 12.10, both monitors are ASUS (Main:VH238H Second:VE247H) and my GPU is a GTX660 Ti.

Possibly related: When I do Ctrl+Alt+F1 I am prompted to login, then the screen fades to black. Same issue occurs when I use "Big Picture" mode in Steam.

What's strange is that it seems the login screen is at proper resolution, and right after logging in, I get this message:

Error Message

share|improve this question
    
Now put all this relevant information in your question. And then let's clean up the comments. It's not a discussion forum. :) Still open: 3) What happens in a new user or Guest account? –  gertvdijk Jan 16 '13 at 20:51
    
Then the only reason I can think of for failure in your account is a left-over per-user Nvidia settings file. There must be some ~/.nvidia-settings-rc there! –  gertvdijk Jan 16 '13 at 21:00
    
No, in your home directory, ~ points to your homedir and .-prefixed files are hidden. Verify in your terminal (as user, not root/sudo!): ls -al ~/.nvidia-settings-rc –  gertvdijk Jan 16 '13 at 21:10
    
I deleted it and after logging out and back in, still the same. –  Dan Jan 16 '13 at 21:32
    
@Dan You have just got to delete your nvidia drivers and try the answer provided here: askubuntu.com/questions/442851/… Remember that your lightdm file will be as /etc/lightdm/lightdm.conf instead of being as /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf . So wherever the answer says to modify /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf you have to modify /etc/lightdm/lighdm.conf –  Venki Apr 26 at 6:46

2 Answers 2

a quick fix that may or may not work is try making a new user, this will force the x.org to reconfigure along with the Nvidia settings; At-least for that particular user.

if anything this wont really fix your problem, just a possible short term work around.

you can do this to your current user by trying dpkg-reconfigure x.org (also to nvidia-settings)

share|improve this answer

I had a problem like that too. I fixed it by removing /etc/X11/xorg.conf /etc/X11/xorg.conf.failsafe and /etc/X11/xorg.backup.
Nvidia drivers can be a real pain in the backside sometimes.
Remember to remove those files using sudo, otherwise you can't remove them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.