Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a problem after the last update, the booting to command line problem

I even can't start in the graphic fail system "xfail":

X: cannot stat /etc/X11/X (no such file or directory), aborting

I found some one mentioning a solution which is installing ubuntu-dektop though apt-get but it failed due to this error:

Unmet dependencies " the dependencies are xserver-xorg-video-all and xserver-xorg-input"

Tried to install these first also another dependencies problem.

Solutions I tried:

  • removing and installing nvidia driver
  • removing and installing xserver
  • Tried different versions of nvidia including the latest one which is the one I had before the update

Any ideas?

share|improve this question
Which version of Ubuntu are you using? – htorque Feb 2 '11 at 8:06
Ubuntu 10.10 Maveric – bhappy Feb 2 '11 at 22:55
up vote 1 down vote accepted

If you have partially installed updates you can complete those with dpkg --configure -a

You can fix broken dependencies with apt-get --fix-broken install

At that point you should be able to fully install X.

share|improve this answer
I'll try that now and get back to you – bhappy Feb 2 '11 at 22:55
Shapr you are the best man I have been struggling for days Just for further information what I did is thus I solved the dependencies using shapr post then removed nvidia and xserver installed new fresh ones installed ubuntu-desktop then start gdm service all good now Commands used 'nvidia-uninstall' to remove invidia 'apt-get install ubuntu-desktop' to install ubuntu desktop 'service gdm start' to start gdm note that the nvidia driver I installed is the latest for my graphic card from nvidia website using sh command – bhappy Feb 2 '11 at 23:13
Shapr i als ran into the same problem and your answer solved my issue as well thank you – antman1380 Feb 6 '11 at 2:00
If you like the solution, vote it up! – shapr Feb 7 '11 at 4:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.